2

After installing Ubuntu Server 10.04.1 on a new x86_64 kvm instance (Debian 6.0 hosted) I'm getting -apparently- ramdon disconnects from the server.

Read from remote host myserver: Connection reset by peer Connection to myserver closed

All TCP connections are dropped (ie. ssh and MySQL server) but icmp traffic still gets accepted and responded to (ping works fine all the time).

% ssh myserver ssh: connect to host myserver port 22: Connection refused

% ssh myserver ssh: connect to host myserver port 22: Connection refused

% ssh myserver ssh: connect to host myserver port 22: Connection refused

[...]

10 to 20 seconds after, I can, "magicaly", connect normally again.

I've checked dmesg, messages, auth and syslog logfiles, nothing appears on them (no failed connections attempts are shown).

If I install the OS directly on the physical server (a Dell 2950) I get exactly the same extrange behaviour, which leads me to think that may be an OS config/bug related problem.

My laptop, as well as the rest of the clients, are on the same subnet as the server connected to the same switch, no routing or other networking devices are involved.

No iptables or other firewall is configured.

Has anyone faced a similar problem? Any suggestions on how I can deeply troubleshoot this?

5

The first thing I would check is if you have any other machines with the same IP on the network. If so, they'll send RST to any TCP traffic they don't recognise which will cause what you're seeing.

  • 1
    +1. This is, in my experience, the most common explanation. Check the logs of the server for IP conflicts. IPwatchD can help you locate the conflicting system. – pehrs Mar 1 '11 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.