I have an (old) SMC-001 IPMI device on an (old) X6DVL-EG2 motherboard. My problem is that I cannot access the BMC from LAN. I'm also getting some interesting output from ipmitool.

First, the setup. I enable Console Redirection in the BIOS, turn BIOS Redirection after POSt to "disabled". I then modprobe'ed for ipmi_msghandler, ipmi_devintf and ipmi_si. I then found ipmi0 under /dev. So far so good. Since I want console redirection over serial, I modified /boot/grub/menu.lst:


I then modified "/etc/inittab" as follows:

S1:12345:respawn:/sbin/agetty -L 19200 ttyS1 ansi

Networking I set as following, using "ipmitool"


The above are correct for my environment.

To test it I do:

ipmitool -I open chassis power off

which responds by powering off the machine.

When I to access from another computer on the network, however, I get an error message:

host# ipmitool -I lanplus -H -U Admin -a chassis power status
Error: Unable to establish LAN session
Unable to get Chassis Power Status

"Admin" seems to be a valid user name:

host# ipmitool -I open user list 1
2   Admin            true    false      true       USER

The interesting output from ipmitool I initially mentioned:

host # ipmitool -I open lan set 1 access on
Set Channel Access for channel 1 failed: Request data field length limit exceeded


newload4:/home/gjones # ipmitool channel info 1
Channel 0x1 info:
Channel Medium Type   : 802.3 LAN
Channel Protocol Type : IPMB-1.0
Session Support       : session-less
Active Session Count  : 0
Protocol Vendor ID    : 7154
Get Channel Access (volatile) failed: Request data field length limit exceeded

The output of "ipmitool -I open lan print 1" is here:


Any help/suggestions is greatly appreciated; I've been working with this thing for a few hours now with no success.


I'm managing to do the same thing with these BMC (SuperMicro SMC-0001) on two SuperMicro servers. I didn't try to setup the console redirection yet because I ran onto a "privilege level" problem on one of the two BMC :

# ipmitool user list 1
ID  Name         Callin  Link Auth  IPMI Msg   Channel Priv Limit
1                true    false      true       NO ACCESS
2   ADMIN        true    false      true       USER
Get User Access command failed (channel 1, user 3): Parameter out of range

The user 2 (ADMIN) should have administrator privileges, but the common way to fix it doesn't work :

# ipmitool user priv 2 1 4
Set Privilege Level command failed (user 2): Request data field length limit exceeded

Then I used "tshark" and "IPMIView" on the other server to "watch" the raw command that IPMIView send when changing a user privilege. Here you go :

# ipmitool raw 0x06 0x43 90 02 04

( 02 = UserID , 04 = Administrator privilege )

You can also reset the password for this user (2)

# ipmitool user set password 2 ADMIN

And to connect from an other host you'll have to use a specific driver

# ipmitool -o supermicro -H my.ipmi.host.ip -U ADMIN -P ADMIN mc info
Device ID                 : 0
Device Revision           : 0
Firmware Revision         : 1.4
IPMI Version              : 1.5
Manufacturer ID           : 5053
Manufacturer Name         : Unknown (0x13BD)
Product ID                : 33025 (0x8101)
Product Name              : Unknown (0x8101)
Device Available          : yes
Provides Device SDRs      : no
Additional Device Support :
    Sensor Device
    SDR Repository Device
    SEL Device
    FRU Inventory Device
    IPMB Event Receiver
    IPMB Event Generator
Aux Firmware Rev Info     : 

Voila, 'hope it helps


  • I suppose this worked, because now when I try " ipmitool -o supermicro -I lanplus -H <IP> -U ADMIN -P ADMIN sdr elist " I get the expected result. Thank you! I'm not registered, so I can't upvote, but I'll accept the answer. If someone else sees this, please vote for this answer :) – Kendall Sep 7 '11 at 18:09
  • @Kendal: the "-o supermicro" option makes ipmitool to use Supermicro's proprietary network authentication, then the "-I lanplus" option doesn't do nothing. – Fravadona Oct 13 '11 at 13:33

I see the board has two ethernet ports. Have you checked the other IPMI channels for LAN channels?

ipmitool channel info N

(Where N is 2 - 9) On my Intel SE7501 boards, the IPMI LAN channels are on both 6 and 7.

To get mine working, I had to set each channel's macaddr to the MAC of the NIC. I also had to set a password for the default user.

Your board specs show it supports IPMI 2.0, but I agree w/Daniel Lawson - try the IPMI 1.5 lan interface. And since OpenIPMI is the default, you don't need to specify '-I open'.

host# ipmitool -I lanplus -H -U Admin -a chassis power status

You're connecting to the IP address here


But you've set the IP address of the IPMI controller to here, and this is verified in the output of "ipmitool -I open lan print 1" you pastebinned.

You need to use the IP address of the IPMI controller when making a LAN connection.

I can't comment on the other commands you're seeing issues with. As it's an older IPMI controller, it's possible it doesn't support what you're requesting?


The lanplus interface is the IPMI 2.0 LAN interface. Try the lan interface (IPMI 1.5) instead?

  • Whoops. That was a typo on my part. To confirm, I just tried the ipmitool command again using the correct ( address and get the same "Unable to establish LAN connection" response. – Kendall Mar 3 '11 at 22:50

Are you able to ping the IPMI IP (

Is there a dedicated IPMI port? If the ethernet cable is not connected to the mgmt port when the machine first powers on it's likely that the IPMI board will 'share' the eth0 port. If you issue this command: ipmitool mc reset cold it will renegotiate and choose the proper port.

  • 1. Unable to ping the IPMI address. When I try to set "access on" for the channel, it responds with "Set Channel Access for channel 1 failed: Request data field length limit exceeded". 2. The IPMI port is not dedicated on this card, it piggybacks on eth0. – Kendall Mar 4 '11 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.