0

I'm trying to upgrade using package python-2.4.3-43.el5.x86_64.rpm, but everything I do so I get a failed dependency requirement for libpython2.4.so.1.0, but I've checked /usr/lib64 and the file is there. The current version of python that is installed is python-2.4.3.27.el5_5.3.x86_64.

Any idea why this may be failing to install when that libpython file actually exists?

  • what is the output of rpm -q --whatprovides /usr/lib64/libpython*? – JeffG Mar 3 '11 at 21:46
  • python-libs-2.4.3-43.el5 – hsatterwhite Mar 3 '11 at 21:51
  • what is the output of rpm -Uvh python-2.4.3-43.el5.x86_64.rpm ? – JeffG Mar 3 '11 at 21:57
0

Even though this sounds like a 64-bit machine, there are often a lot of 32-bit dependencies. Have you tried installing both x86_64 and i386 versions of the dependencies?

  • This is indeed a 64-bit machine and that has crossed my mind. Haven't tried it yet. That's something I'll give a go tomorrow. – hsatterwhite Mar 4 '11 at 3:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.