I'm having this strange issue with this server (HP Proliant with broadcom NIC) running Windows 2008 R2. The network card takes almost 2 minutes to activate. That is, when you disable/enable the card it won't actually "connect" until about 2 mins. The NIC speed is 1Gbps. The switch is set to FULL/1000 (I already tried changing this to auto but that didn't work).

I already installed the latest broadcom drivers and also disabled ipv6 for the card. The server has two cards and it does the same with the two cards. After the card is active (connected) it runs fine.

The problem is that when we reboot the server, there are a couple of services that depend on network connectivity but, as they're so slow connecting to the network, these services will fail. I had to change many of these services to "Automatic Delayed" but I really would like to find the actual cause of the issue.

I suspect some Windows issue but can't find anything. Any help will be appreciated.

Regards, Craconia

UPDATE: I found the solution! It was the "QoS Packet Scheduler" on the NIC properties. I removed the checkmark there; disabled/enabled the card and it was ready in about 10 seconds! I hope this helps someone else with the same problem.

Thanks all for the comments.

  • Up to date on firmware and PSP? – Chopper3 Mar 4 '11 at 17:50
  • Yes, this was a new deployment (used the SmartStart media) and then the latest PSP and firmware DVD. Thanks. – Craconia Mar 5 '11 at 1:41

What kind of switch are you using? I'm betting you have a Cisco switch that doesn't have portfast enabled.


By default when you establish link on the higher end Ciscos it will go through a spanning tree discovery, and trunking discovery before it ever even negotiates speed. I've seen this cause exactly the kind of trouble you describe.

  • 1
    The port indeed didn't have portfast enabled. I enabled it while doing troubleshooting and gained around 15 seconds for doing that. however, 1 min, 45 seconds for the card to get activated is unusual. I posted an update. – Craconia Mar 5 '11 at 1:37

Do you have the Broadcom teaming enabled? Have you tried disabling it?

Also anything in the System event log?

  • This was a new server and I never configured teaming. I double-checked that (as HP media install a lot of stuff) but teaming was disabled. Nothing on the system logs. I updated my original question with solution. Thanks. – Craconia Mar 5 '11 at 1:42

You said the switch is on FULL/1000 but did you set the servers'NIC to FULL/1000 too or is it still configured to negociate ? That could be the reason of at least some of the slowness (trying to negociate with a switch that cannot).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.