2

I'm pushing out a new Win7 image to several machines using WDS, unattend.xml, and oobeunattend.xml.

Naturally you have to create the local user in the OOBE experience but it isn't something I want to keep there.

I added this to my OOBE.xml but it isn't working, its even after my domain joining component:

<settings pass="auditUser">
- <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
 - <RunSynchronous>
   - <RunSynchronousCommand wcm:action="add">
      - <Credentials>
           <Domain>DOMAIN</Domain> 
           <Password>PASSWORD</Password> 
           <Username>administrator</Username> 
        </Credentials>
        <Order>1</Order> 
        <Description>Removes original test user</Description> 
        <Path>net user temp /del</Path> 
      </RunSynchronousCommand>
    </RunSynchronous>
  </component>
</settings>
1

Woohoo I got it!

In my answer file, instead of doing a script (which was running in the Specialize component anyway, and the user was created in oobeSystem) in specialize, I added Windows-Shell-Setup --> FirstLogonCommands and put the command there. Worked perfectly! Thanks!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.