0

I have a Ubuntu server with the following in /etc/network/interfaces:

auto eth0
iface eth0 inet static
        address a.b.c.d
        netmask 255.255.255.0
        gateway a.b.c.254 

When I run /etc/init.d/networking restart, it works as expected.

In the same LAN, I have a DHCP server. From time to time, Ubuntu server unexpectedly loses its static IP, and gets one from a DHCP for an unknown reason to me.

Running /etc/init.d/networking restart corrects the address to the desired one.

What is the cause of this issue, and how can I fix it?

1

Happend to me sometime, solved by uninstalling dhcp client. No use on server anyway.

2
  • Oh I dunno. I use dhclient on servers sometimes. It's all fine if the DHCP server is handing out static leases. – Tom O'Connor Mar 9 '11 at 0:12
  • Perfectly suitable for me... No need for dhcpclient – Boban P. Mar 9 '11 at 7:54
2

Something invoked dhclient without specifying an interface.

0

I had this issue and it turned out that ' cloud-init ' was installed on my system. It had configuration files in /etc/network/interfaces.d/ for eth0 which defined a DHCP setup, while I had static config in /etc/network/interfaces

I removed the cloud-init package and manually removed the files in /etc/network/interfaces.d/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.