I am looking after a small (12 PCs) network mostly made up of Windows 7 PCs about half 32-bit with the remainder 64-bit or Vista. WSUS is setup on the server and all computers are configured via group policy to retrieve updates from WSUS.

It seems that at about 1700 GMT last night all of the Windows 7 PCs downloaded and offered Windows 7 SP1. My well trained highly technical users diligently installed SP1 which promptly hosed their computers.

More specifically when the they restart the install process hangs with Fatal Error C0000034. I have been able to restore some PCs using System Restore or Recovery Images the remainder I seem to be able to fix from recovery console by restoring the registry manually.

I am at a bit of a loss as to why SP1 has hosed all of the PCs at once, there is nothing unusual on there and all have been rebuilt within the last 8 months.

  • Windows 7 x64 Ultimate
  • Visual Studio 2010
  • Office 2007
  • Symantec Endpoint Protection
  • Tortoise SVN

Anyone else experienced this today? and if so has anyone found a solution. I have blocked the installation of Win 7 SP1 with the SP1 blocker tool provided by Microsoft.

Any help appreciated.

  • 2
    +1 For "My well trained highly technical users..." – jscott Mar 15 '11 at 0:45

I've had this exact same problem on two of our customers computers. This thread has been of some help to me, but I still haven't figured out whats causing the error.

Update: I spent almost two hours on the phone with Microsoft Tech Support on this issue. The support tech had me do the following steps:

  1. Boot into Windows Recovery and choose command prompt then run the following commands:
  2. Reg load HKLM\BaseSystem C:\Windows\System32\config\SYSTEM
  3. Reg Delete "HKLM\BaseSystem\CurrentControlSet\Control\Session Manager" /v SetupExecute
  4. Reg add "HKLM\BaseSystem\CurrentControlSet\Control\Session Manager" /v SetupExecute /t REG_MULTI_SZ
  5. Reg unload HKLM\BaseSystem
  6. Restart the Computer.

I'm posting more info as we learn it our blog.



Try the System Update Readiness Tool. Also (I know it is a different error) but see if this question on SU helps.


This worked for 35 computers in our school. http://social.technet.microsoft.com/Forums/en-US/w7itproinstall/thread/1c9a7151-b48c-4a98-aae7-a4b82682ea8e/#bcabda57-7338-499f-aee2-d708e76df315

  • Seems to be the way forward, of your 35 computers how many of them are now running SP1? Of the machines that I could not restore from a backup I got up and running by manually restoring the registry hive then several rounds of sfc /scannow to get the files back to stock. – Richard Slater Mar 10 '11 at 21:13

Here is the solution I found for getting workstations back up and running again, mainly taken from this rather old question on TechNet:

  1. Get into the Windows Recovery Environment.
  2. Open up the command prompt.
  3. Change directory to C:\Windows\System32\config (note: this might actually be D: if the reserved partition has been mounted as C:)
  4. Copy rename the following files to .old

    • default -> default.old
    • sam -> sam.old
    • security -> security.old
    • software -> software.old
    • system -> system.old
  5. Change directory to regback

  6. Copy default, sam, security, software and system to the parent directory (copy * ..)
  7. Restart
  8. Run sfc /scannow to restore the modified files (you may have to run the same command several times)

After that I was back to pre-SP1 state and everything appears to be working.


There have been numerous "fixes" for this issue, and a number of causes. The only thing that has fixed EVERY affected machine every time is the following: (note: if you don't have a functioning local administrator account then you can not use this fix without using a SAM edit boot CD to override the local admin account)

1) reboot your Windows 7 machine after the failure message

2) Select "Launch System Repair" from the failed boot menu

3) let it run through the attempted auto-repair (it will fail)

4) select the advanced options link near the bottom of the repair failure dialogue

5) launch the command console (the last option)

6) change to your local system disk (c: unless your HDD has other partitions for recovery etc...). You know it's the right disk if it has the folders "Windows" and "Program Files (x86)"

7) run the following 3 commands:

cd \windows\winsxs

ren pending.xml pending.xml.bak

copy reboot.xml pending.xml

8) reboot the computer

9) SP1 will try to apply 3 times and fail. When it fails it will roll back to pre-SP1 and boot normally

10) all fixed (this worked for 17 computers today)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.