I'm setting up the network for a company, and facing a weird issue. The network is very simple: An xDSL modem/router, a switch, a bunch of windows clients (XP, vista, 7). The room is wired and provides RJ45 plugs in the walls, which are all converging to the switch, which is uplinked to the router. The DSL router also serve IP addresses via DHCP.

Here is my problem: - One of the clients (Vista), does not work if it's plugged into the wall, but works when I connect it directly to the switch. My first guess was that the wall plug was the culprit, BUT when I connect my linux laptop on this plug, it works perfectly. On the Vista machine, when I look to the network adapter with a plugged in cable, the LEDS of the NIC are green but DHCP fails, and putting a static IP does not help.

I'm running out of ideas... Can you help me ? Thanks in advance!

2 Answers 2


I'd venture a guess that this laptop has an extremely cheap NIC chipset, realtek or something similar; and it's very sensitive to noise or poor quality cabling. If you have a tool to check line quality, test the wall outlet; I'll bet it's less than optimal. It's picking up the link, hence the green lights; but data is getting corrupted bad enough that it doesn't actually work.

  • Sounds good, even if it's the opposite : my laptop got an iwl3945 and the PC is a cheapo'. On the other hand, I tried to ping the gateway from my laptop with various packet size (up to 65507), and always got 0 packet loss.
    – MatthieuP
    Mar 10, 2011 at 14:11

Usual Q, is the pc fully upto date with latest drivers?

It sounds to me like driver cant negotiate the right connection when running through the wall cabling. Have you eliminated the cable between wall plug and card as a potential problem? if those are eliminated its likely to be a faulty network card

  • The PC runs the latest versions of the NIC drivers, and this NIC works perfectly when it's connected directly to the switch. Also, the cable between the wall and the PC works too, as I'm able to connect with my linux laptop using this cable/plug.
    – MatthieuP
    Mar 10, 2011 at 13:07
  • is the switch auto MDI-X capable, if not is the Nic in the PC auto MDI-X capable, if both aren't and the cable running through the wall is somehow a crossover (or the cable between wall and switch/pc) then it wont be able negotiate anything. - you have eliminated most other problems though Mar 10, 2011 at 13:14
  • 1
    Try runniong the same hardware from a bootable Linux CD/USB key. If it works, you know it's a software problem.
    – symcbean
    Mar 10, 2011 at 13:17
  • I think that they are both autosense capable. I tried to tweak various things on Vista's side (but still with no luck): disabling power saving stuff, disabling autosense negocation.
    – MatthieuP
    Mar 10, 2011 at 14:13
  • @symcbean: Good idea, I will try that.
    – MatthieuP
    Mar 10, 2011 at 14:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .