I am having problems sending email from a domain I host myself.

I have omitted the actual ip address in question, I am not sure how secure it is that I post it. However the problem is as follows:

According to my ISP the reverse was done for the my IP to point to the FQDN taht follows.

(XXX.XXX.XXX.XXX) -> mymachine.domain.com

However I still get email undelivered:

host inc.wanadoo.es[xxx.xxx.xxx.xxx] refused to talk to me: 550 Reverse DNS lookup failed for host xxx.xxx.xxx.xxx.

and upon testing I get the following error:

Reverse for xxx.xxx.xxx.xxx points to an unknown host name (mymachine.mydomain.com).

The weirdest, perhaps, is that using some tools (i.e mxtoolbox) to check that the rDNS agrees to my SMTP banner, all checks fine, however, it fails when I use other tools.

What can be the error?

Do I need a reverse for every single domain I host or is it enough with the one for the mail server?


Ubuntu Server 10.04. LTS


Postfix version 2.x.x

Edit: In trying what you suggested I received the following:

first test

host -t a neo001.neoclash.com

mymachine.mydomain.com Using domain server: Name: Address: Aliases:

Host mymachine.mydomain.com not found: 3(NXDOMAIN)

second test

host -t ptr

host -t ptr Using domain server: Name: Address: Aliases:

Host not found: 3(NXDOMAIN)

zone configuration

$TTL 12H
$ORIGIN mydomain.com.

enter@  IN  SOA ns1.mydomain.com. postmaster.mydomain.com. (
        1D )
            IN              NS              ns1.mydomain.com.
            IN              NS              ns2.mydomain.com.
            IN              MX      10      mail.mydomain.com.
            IN              MX      20      mail.anotherdomain.net.

mydomain.com. IN A

www IN A

mydomain.com. IN TXT "v=spf1 a mx ip4: ip4: ~all"

localhost IN A

mail IN A
mail IN A
ns1 IN A
ns2 IN A
  • In the configuration file that you posted there is no A record for neo001 – adamo Mar 14 '11 at 13:51

Try this:

host -t a mymachine.domain.com

This queries Google's public DNS servers and asks them what the IP address for mymachine.domain.com is. Now assuming the IP address is try this:

host -t ptr

Is the response mymachine.domain.com ? If yes, then you have to wait a while for DNS caches to expire and read the new information. If not, then depending where the unexpected result appears, there exists a problem to be solved.

  • it did not seem to work – user74376 Mar 14 '11 at 11:18
  • Assuming the host in question is [I removed the server name], the first query failure means that the name does not exist, meaning that ns1 and ns2.[domain here].com are not configured to serve the A record for this name. Fix this first. – adamo Mar 14 '11 at 11:19
  • the A record seems fine where how can I post the sample file with the record? – user74376 Mar 14 '11 at 11:39
  • You posted the configuration file and there is no A record for neo001 – adamo Mar 14 '11 at 14:16
  • Either that, or similar to the www line. – adamo Mar 14 '11 at 20:59

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.