I am trying to upgrade a Dell R310 from the 1GB RAM that it came with (1 stick - 1GB UDIMM - Hynix part number HMT112U7BFR8C) to 16GB using 4 x 4GB Dual Rank RDIMM 1333MHz memory modules purchased directly from Dell. However, I cannot get these new chips to work.

Dell don't seem to have any idea why they don't work, and they have already replaced them twice with no luck. The motherboard has also been replaced by Dell in case that was fault but it still doesn't work.

I have also tried the sticks in lower capacity configurations:

  • 1x 4GB stick in slot 1 for total 4GB
  • 1x 4GB stick in slot 1, 1x 4GB stick in slot 2 for total 8GB

None of these combinations work. As soon as the original unbuffered DIMM is put back in by itself, it works fine.

I have checked that the combinations and slot choices are in accordance with the Hardware Owners Manual and it all checks out.

Has anyone seen this problem before? Any idea what we need to do to get this working?

  • Are they properly inserted in their slots ? by order ? I upgraded from 1RAM to 4RAM in a 2*2GB cards it worked well. – user80344 May 4 '11 at 10:51

Just ran into the same problem with an R310. Took quite a bit of digging but the link to the R310 Tech Guide helped. The 1GB UDIMM uses 128Mb x8 chips which is why it works. The Samsung sticks they keep sending you use 256Mb x8 chips and as you found in the Tech Guide the R310 won't work with 256Mb chips. I ran into the same problem using some memory we pulled out of an R710 server but they were 256Mb x4 chips so it was a double no-no.

Here is what I've found regarding memory. The actual DRAM chips on the memory module have differing numbers of lines. This is also referred to as the rank width, e.g., x4, x8, x16. The DRAM chips are also different sizes, e.g., 128Mb, 256Mb, 512Mb. The easiest way to explain ranks is to think of each rank as a virtual DIMM. So a single rank module is just that; a single memory module on a single physical DIMM. Dual rank memory actually has 2 memory modules on a single physical DIMM (it's deeper than that but this is the easiest way to visualize it).

So the bottom line is that the R310 will only accept DIMMs that are made out of 128Mbit or 1Gb/2Gb chips that are x8 devices. Or at least that's my story and I'm sticking with it until Dell tells me otherwise; e-mail to them is out and I'll let you know if they say something different.

Link to Hynix part: http://www.hynix.co.kr/datasheet/eng/module/details/module_20_HMT112U7BFR8C.jsp?searchType=2&menuNo=1&m=1&s=1&RK=20&RAM_NAME=

A link to an excellent briefing from Intel: http://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=2&ved=0CDsQFjAB&url=http%3A%2F%2Fdownload.intel.com%2Feducation%2Fhighered%2Fsignal%2FELCT865%2FClass2_21_lab_and_project_assignment3.ppt&ei=VKOiT-yKDoau9AS86730CA&usg=AFQjCNHOMlxRyI0C8F7GIdwMkU8h1ZOmyQ&sig2=nLNmplaHcJjbv7rktoqb2Q

Slide 13 is the key, but the entire package is very good depending on your level of geekdom :)

Update: Confirmed with Dell except that I was wrong about requiring 128Mb and smaller chips. The Foxhollow platform does support 1Gb and 2Gb chips. See here: http://cache-www.intel.com/cd/00/00/43/26/432686_432686.pdf


Dell's documentation isn't all that great. But I would start by making sure the BIOS is up to date. Then look inside the BIOS to see if there are some settings related to memory.

This is the manual

Look at page 35+ for memory related stuff. Slot configuration is important per the documentation.

But really Dell should be able to fix this for you. Try to get your service call escalated.

  • I agree, this should be put back on Dell. – DanBig Mar 14 '11 at 13:42
  • Dell have been involved several times already. They are coming out again this afternoon, but we are now at the point where we just need this working, regardless of how! – Mark Hatton Mar 14 '11 at 14:26
  • The manual link that you sent is different from the links I had seen previously. I note that there are various restrictions such as "No support for 256Mb/512Mb technology or x4 and x16 DRAMs on RDIMM". The chips that they keep sending us are Samsung model M393B5273cho-ch9. However, my knowledge of RAM is not good enough to know if this is compatible or not! Their product spec sheet is here: samsung.com/global/system/business/semiconductor/family/2010/1/… (page 7, about halfway down). Anyone got any clue if it's compatible? – Mark Hatton Mar 14 '11 at 14:27
  • More "manual" goodness @ ftp.dell.com/manuals/all-products/esuprt_ser_stor_net/… – TOOGAM Mar 10 '17 at 18:44

had the same problem with a T110 and RDIMM. RDIMM is only supported with XEON CPU´s on the R310 RDIMM can´t be used with Desktop CPU and Xeon L3206!



To use 16GB of memory you will need XEON processor and a quantity of (4) 4GB sticks that are dual ranked and use a x8 data width (2Rx8).


I experienced the same issue with our PowerEdge R310 where the only support for RDIMM is with a Xeon processor (ours had a Core i3). There was a single ambiguous reference in the Technical Manual that confirmed this.

To use all six slots requires RDIMM, so the bottom line is that the UDIMM maximum is 4 x 4GB Dual Ranked DIMMs leading to the 16GB maximum.


The Dell Tech Guide provides detailed information that should help. http://binar.pl/p/poweredge-r310/poweredge-r310_tech_guide.pdf

Look in section 8.1 (pages 36-37) for information on which RDIMMs or UDIMMs to use to obtain different memory configurations. The speed and rank are also important.

  • 1
    How is this different from cwheeler33's answer of more than five years' previous? – MadHatter Oct 6 '16 at 5:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.