I am trying to get localhost working on my machine. I am using Mac OSX Snow Leopard. The http://localhost in the browser works, MAMP shows the servers are running all well, and displays the start page.

However, when I try Sequel Pro's 'Socket' tab, with root, root as username and password, it says the username or password are wrong. Badly stuck here, please help!

PS: So what I am trying to do? I am trying to install a local wordpress installation in my localhost folder.

enter image description here


2 Answers 2


First i'd suggest you reference where you got your MAMP build from for local root passwords as they default them to something generally. Also in MySQL you usually have to list a database that you are connecting to (whether you are root or not) for example

mysql -h localhost -u root -p yourpassword yourdatabase

or you can let it prompt you for the PW

mysql -h localhost -u root -p yourdatabase

also if localhost isn't being resolved, you can use

I hope this helps you in your endeavor to put up your wordpress!

  • MySQL uses a filesystem socket to connect to 'localhost' - and a network socket to connect to In the original post the client is connecting but access is denied - this implies different settings in the mysql.user table for localhost and the row which is matched by (i.e. a network connection)
    – symcbean
    Mar 14, 2011 at 13:35

What value did you put in the 'host' field when you try to connect to your database? Did you put in 'localhost'?

When you go to http://localhost does the Wordpress installation page show up? If you go through the Wordpress initialization steps, can it connect to your local database?

You can check that your website is listening on localhost by opening a terminal window and attempting to connect to the socket:

telnet localhost 3306

If that can't connect, your MySQL database isn't running (or is on a non-standard port).

You must log in to answer this question.