Symptoms: The user cannot open new PDF's. When we look on the TS process list, we can see multiple acrord32.exe's, one for each attempt to open a PDF after the hang occurs. The user/Citrix Control Panel can not see the process. After a while an error saying referring to the DDE service may pop up, but this is bogus error message as far as we can tell. (We have tried enabling the service too.)

We have been able to figure out that this happens consistently when the user uses the "x" on the right click "drop down" menu from the Windows taskbar in Vista/7 to close Reader, but it seems it can also occur when closed in other ways, although rarely.

It seems that only a few 5-10 of our 1000+ users get this error at all, and about 2-3 of them get it a lot more than the rest. This is at least partially because of patterns of use.

We run Windows 2003 R2 fully patched as of now. We run Presentation Server 4.5. We have tried Adobe Reader 6, 7, 8, 9, X. Same error on all.

Information on this is scarce, but we have been able to find a few posts on it. Most not offering any solution. The only solution suggested is to install the v 12 Xen (Citrix) client, but that doesn't help.

Some of the better posts describing the same error: http://tech.groups.yahoo.com/group/thin/message/144256


Any help would be very much appreciated.

4 Answers 4


The registry hack I gave you recreates/resets standard Windows execution for '.exe' files. Right after I applied this fix Windows was able to associate PDF files with my default PDF reader software ( in my case with Foxit Reader) and more importantly to remember settings. This was an easy fix for me when I was loged in as administrator. Next step was to disconnect/log off all Wyse terminal clients and start new session(s) after which end users were able to do the same thing: double-click on PDF file, and after Windows promt which application to use to handle PDF files and appropriate steps ( application selection) they all had functionality back.


We finally found the problem (more or less).

In certain combinations of client OS', Citrix versions and TS OS' combined with (all as far as we know) versions of Adobe Reader (but possibly other programs) you can experience this.

This being that Citrix believes that it has closed the program, but in reality it still runs under the user on the TS. This situation leads to further instances of Reader being spawned (since it doesn't run...) when a user opens a PDF. None of which become visible to the user.

We don't know exactly where the fault lies, but we know now for sure what causes it, and it is easy to avoid. If the user closes Adobe Reader (or a group of Citrix apps) using the right-click-close on taskbar, this will in many (we think not always) cases cause Citrix to think it closed Reader, but Reader will still run, and you got the situation.

We solved this by simply instructing our users not to close programs this way, and if they get into the situation, they can log out and back in again, and all Reader instances will have closed themselves.

I write this down here because me and my colleagues spent hours and hours trying to get at this.

Thanks to everyone that answered!

PS: Read my question for more info.

  • (I hope it is acceptable to answer ones own question... if not please correct me.)
    – Gomibushi
    Jun 16, 2011 at 8:08

I've got same exact problem on my two Win2K3/Citrix boxes. Same DDE connection error notification, same thing with multiple instances AcroRd32.exe processes running and same strange system hungs and disconnections of my ICA clients...

I haven't had time enough to test ICA client v. 12 solution but I have found the way around, or better yet, managed to bybass the problem and keep the functionality (ability to open and read PDF documents that is) by installing free version Foxit Reader.Now all my Wyse terminal ICA clients can manage our patients' records.

Even better I found Foxit Reader lighter and less resource hungry. I am done with Adobe Reader on my WIndows/Citrix machines.

  • We have considered Foxit Reader, and yes I have no doubt it is probably the better piece of software, but it's also about what our customers are used to use etc... We just might have to sell them on this. Thanks a lot for the input!
    – Gomibushi
    Mar 24, 2011 at 7:28

This is also what I did to fix the problem Windows Server 2003 was having with opening PDF files. I merged this *.reg file to Windows Registry and PDF reading functionality is back now.

A-copy this three lines :

Windows Registry Editor Version 5.00 


@="\"%1\" %*"

B- Open Notepad and paste those three lines into Notepad.

C- Save Notepad document as PDF-FIX.reg ( Windows Registry file)

D- Double-click ( or do right-click and select "Merge" ) on PDF-FIX.reg

E- try opening PDF file

F- When/If prompted what program to use to handle *.PDF files select your preferred software (either Adobe od Foxit PDF Reader )

You should be OK then.

  • I'm quite reluctant to change anything as fundamental as that on a production TS, and we have no real way to test if that change will have any effect on the problem in any other way as reproduction is hard. Do you have any (official perhaps?) documentation on what exactly this does? (thanks again!)
    – Gomibushi
    Mar 31, 2011 at 9:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.