1

I logged in to a Windows Server 2008 VirtualBox VM as Abbas (local, standard-user account), ran cmd.exe as Administrator and then deactivated the Administrator through:

net user administrator /active:no

Please don't ask why I did that, I am still trying to figure out what the hell was I thinking. I have the administrator's password but I just can't figure out how to activate the account. Any suggestions, other then rebuilding the VM?

  • is thing a member of a domain? – tony roth Mar 15 '11 at 21:59
  • No, it's not. Local, standard user and local admin. – Abbas Mar 15 '11 at 22:24
3

If you don't have any other accounts that are members of the "Administrators" group then there is no "supported" method for gaining Administrator access again.

Having said that, you can boot the Windows setup DVD image, attach to the SAM registry hive on your locked-out installation, and re-enable the Administrator account (see http://4sysops.com/archives/offline-enable-the-built-in-administrator-account-in-windows-7-and-vista/ for some details).

I believe that the canonical NTpasswd bootdisk can also enable the account as well.

  • I am trying out the NTpasswd bootdisk. I'll post an update shortly. – Abbas Mar 15 '11 at 22:02
  • thanks. It worked!!. I tried the NTpasswd bootdisk and played around with the options a bit. I was able to activate the administrator on second attempt. Thank you once more :). – Abbas Mar 15 '11 at 22:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.