I have a linux box running Linux server ubuntu 10.10. I have installed Samba on this linux box and want to share files with my laptops which run Windows Vista home and Windows 7 home. I have been struggling with the setup for almost a month but couldn't get it right. If I try to access share folder from Windows Vista, I get message

"Windows cannot access \\server_ip_address". 
Error code: 0x80070035. The network path was not found.

If I access from Windows 7, then after entering password to login I can see the list of share folders on Linux box. But if I click on a share folder, I get the same error message as above.

Tail /var/log/samba/log.windows7-pc I got the following message:

[2011/03/16 00:17:41.427238,  0] smbd/service.c:988(make_connection_snum)
canonicalize_connect_path failed for service sharemedia, path /root/sharemedia

Here is my setting in smb.conf [global] share modes = yes netbios name = Samba

workgroup = WORKGROUP

wins support = yes

encrypt passwords = true

comment = Tesing sharing using Samba
public = yes
valid users = samba_usr_name

; make sure all files are sensible permissions
create mask = 0660
force create mask = 0660
directory mask = 2770
force directory mask = 2770
directory security mask = 0000

; Normal share parameters          
read only = no
browseable = yes
writable = yes                     
guest ok = no

migrated from stackoverflow.com Mar 16 '11 at 13:38

This question came from our site for professional and enthusiast programmers.


Try enable guest OK. Also are you accessing via IP or via a name?

Also, due to the funny permissions that can sometimes apply to /root, you should try another directory ie /home/someusers/sharemedia/.

This is only half a solution, I can't be sure what the problem is without further troubleshooting.

  • You're right. It's the problem with root permission. I created another folder under a regular user directory and it's working fine now. Thanks a lot. Sorry I cannot vote your answer up. I accidentally migrated my question into serverfault (I don't know why they had that option) and it requires at least 15 reputation to vote up :( I don't know how to migrate back to stackoverflow – chepukha Mar 17 '11 at 21:42
  • @chepukha Don't worry, I did it for you (vote up) :) – Art Shayderov Mar 18 '11 at 8:07

I resolved my problem connecting my Windows 7 box to my Ubuntu samba (11.10). I Had the "Windows cannot access" error (0x80070035 - the network path was not found" when trying to access the server (or share). I tried a lot of things, but when it came down to what actually solved it (all other items reversed) it was the "Microsoft Network client: Digitally sign communications (always)" setting that was causing my problem. Once it was disabled, I could see the shares and map the drive.


Just for a test try to disable IPv6: as described here. Also see ubuntuforums.org.

  • I have disabled ipv6 on Ubuntu since I installed it. Windows 7 can access share folder now even with ipv6 available. Windows Vista however still have problem even after disabled ipv6. Thanks – chepukha Mar 17 '11 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.