-1

I installed Ubuntu in VMWare Workstation 7. My Host (Windows Vista Home Premium Service Pack 2) and Guest machine is connected using NAT connection. Now I want to connect Guest OS (Ubuntu) with Putty, installed in my Host OS, using SSH connection. What settings I have to do in Ubuntu, Vista and Putty?

--Edit--
As per sreimer's instruction I installed openssh-server. Now when I am trying to connect using putty, same error is occured:

Putty Fatal Error - Network error : Connection refused

  • 4
    Try changing the guest adapter to bridged instead of NAT. Bridged will make the host&guest appear on the same subnet. NAT places the guest on a different subnet, like it's behind another router. You can try to configure the VMWare NAT to accept the putty connection from your subnet, but bridged is probably the simplest solution. – Joe Internet Mar 17 '11 at 18:14
6

Install openssh-server on Ubuntu with

sudo apt-get install openssh-server

You should then be able to ssh from Windows (Putty) using the default settings

  • I installed openssh-server. Now when I am trying to connect using putty, same error is occured: Putty Fatal Error - (Network error : Connection refused). – chanchal1987 Mar 17 '11 at 17:58
  • check to see if the ssh daemon is running with ps aux | grep sshd. If not, run /etc/init.d/ssh start – sreimer Mar 17 '11 at 20:57
1

Does $'sudo netstat -nlpt' show sshd running on port 22 ?
Did you start the sshd service with $'sudo initctl start ssh'

0

You have to have ssh service running after you install the openssh-server. Some times it will not start the service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.