I'm trying to upgrade my SQL Server 2008 with Full-Text Search feature. Installation fails on it's very end with something like this in C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20110318_105034\Detail.log:

Slp: Error: Action "ConfigEvent_SQL_FullText_Adv_sql_fulltext_Cpu64_Install_ConfigNonRC_postmsi" failed during execution.
Slp: Action "FulltextConfigAction_install_confignonrc_Cpu64" will return false due to the following conditions:
Slp: Condition "Feature dependency condition for action: FulltextConfigAction_install_confignonrc_Cpu64 The condition tests feature: SQL_FullText_Adv_sql_fulltext_Cpu64. There are 3 dependant features. The feature is tested for results: ValidateResult, Result." did not pass as it returned false and true was expected.
Slp: Condition is false because the required feature SQL_FullText_Core_Shared_sql_engine_core_shared_Cpu64 failed in result Result

I also failed to upgrade Full-Text Index in SQL server 2008.

The only thing worked for me is to uninstall the SQL server, then I installed it again in 2 stages: - Install only the Full Text Index - then I installed all other features

don't know what was the problem in the first place


I had a similar issues with the 32 bit version. I tried a couple of times to install with the same result. When I tried a third time, instead of putting a username/password for the service account, I left it blank and the install worked. I then changed the service account in the control panel applet afterwards. Not sure if this helps anyone, but if someone is having similar issues it is worth trying before going through the uninstall and re-install process.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.