1

I'm trying to use zypper to install gcc on my Amazon EC2 instance running SUSE.

When I try:zypper in gcc

I get:
Retrieving repository 'SLE11-SDK-SP1' metadata [] Permission to access 'http://eu-west-1-ec2-update.susecloud.net/repo/install/SLE11-SDK-SP1/sle-11-i586/media.1/media' denied.

Abort, retry, ignore? [a/r/i/?] (a): i Retrieving repository 'SLE11-SDK-SP1' metadata [error] Repository 'SLE11-SDK-SP1' is invalid. Can't provide /media.1/media : User-requested skipping of a file Please check if the URIs defined for this repository are pointing to a valid repository. Warning: Disabling repository 'SLE11-SDK-SP1' because of the above error. Retrieving repository 'SLE11-SDK-SP1-Updates' metadata [|] Permission to access 'http://eu-west-1-ec2-update.susecloud.net/repo/update/SLE11-SDK-SP1-Updates/sle-11-i586/repodata/repomd.xml' denied.

Abort, retry, ignore? [a/r/i/?] (a): i Retrieving repository 'SLE11-SDK-SP1-Updates' metadata [error] Repository 'SLE11-SDK-SP1-Updates' is invalid. Can't provide /repodata/repomd.xml : User-requested skipping of a file Please check if the URIs defined for this repository are pointing to a valid repository. Warning: Disabling repository 'SLE11-SDK-SP1-Updates' because of the above error. Retrieving repository 'SLES11-Extras' metadata [/] Permission to access 'http://eu-west-1-ec2-update.susecloud.net/repo/update/SLES11-Extras/sle-11-i586/repodata/repomd.xml' denied.

Abort, retry, ignore? [a/r/i/?] (a): r Permission to access 'http://eu-west-1-ec2-update.susecloud.net/repo/update/SLES11-Extras/sle-11-i586/repodata/repomd.xml' denied.

Abort, retry, ignore? [a/r/i/?] (a): zypper in gcc Invalid answer 'zypper in gcc'. [a/r/i/?] (a): a Retrieving repository 'SLES11-Extras' metadata [error] Repository 'SLES11-Extras' is invalid. Can't provide /repodata/repomd.xml : Please check if the URIs defined for this repository are pointing to a valid repository. Warning: Disabling repository 'SLES11-Extras' because of the above error. Retrieving repository 'SLES11-SP1' metadata [-] Permission to access 'http://eu-west-1-ec2-update.susecloud.net/repo/install/SLES11-SP1/sle-11-i586/media.1/media' denied.

Abort, retry, ignore? [a/r/i/?] (a): a Retrieving repository 'SLES11-SP1' metadata [error] Repository 'SLES11-SP1' is invalid. Can't provide /media.1/media : Please check if the URIs defined for this repository are pointing to a valid repository. Warning: Disabling repository 'SLES11-SP1' because of the above error. Retrieving repository 'SLES11-SP1-Updates' metadata [] Permission to access 'http://eu-west-1-ec2-update.susecloud.net/repo/update/SLES11-SP1-Updates/sle-11-i586/repodata/repomd.xml' denied.

I've search for the problem and this thread came up, but offered no solutions.
I've triedsces-activate. Am I doing something wrong?

I should say I'm very new to this, and I admit I don't really know what I'm doing, but I'm trying to learn about setting up and running a server and so I thought I'd throw myself in at the deep(ish) end.

Thanks for reading.

1
  • I'm voting to close this question as off-topic because this is a problem best directed to Amazon support.
    – fuero
    Mar 9, 2015 at 10:31

2 Answers 2

1

That usually means that the URL or media is not accessible anymore (it is sort of like a 404 message with Debian apt-get or Red Hat's yum). From what I gather, it is supposed to pull the packages from Amazon's SuSE's repos, but now those repos are down. You'll probably need to post a message on Amazon's forums to get Amazon to fix it.

0

I am not at all familiar with zypper as a package manager, tho I have used suse v8 and 9. the Big Gui SUSE tool is YasT (not sure on caps).

I am seeing the same thing in other AWS support threads,like so: https://forums.aws.amazon.com/thread.jspa?threadID=53398

so maybe its not you.

I've had very easy success on Ec2 using Centos based AMIs and using yum/rpm and also source compiles.

You should not need to install gcc on a new Ec2 instance,that might be going a bit far into building from scratch.

I generally feel pretty distro agnostic, and don't have a problem switching between debian/ubuntu based types and rpm/yum based types.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .