I followed this tutorial to install gitosis on my homeserver(ubuntu 10.10 server edition): https://help.ubuntu.com/community/Git . After a lot of fiddling around because it didn't work(something with certificate naming) I finally got it to work properly. I added the testproject and everything worked fine. Now I want to add a proper project I'm going to use, but I get this error(the testproject still works): ERROR:gitosis.serve.main:Repository read access denied

This is my gitosis.conf(which is committed and pushed):


[group realproject]
writable = realproject
members = teun@TEUN-PC

[group testproject]
writable = testproject
members = teun@TEUN-PC

[group gitosis-admin]
writable = gitosis-admin
members = teun@TEUN-PC

To create the "realproject" I used these commands afterwards(on my PC):

mkdir realproject
cd realproject
git init
touch README
git add .
git remote add origin gitosis@
git commit -m "Added README"
git push origin master

I get the error after that. When I look on the server in /srv/gitosis/repositories/ the realproject.git is not there, the other 2 projects are though. I hope someone can help me with this?

EDIT: After adding loglevel=DEBUG under [gitosis] to test if I see an error suddenly it worked again. Now I don't know how this is possible so I keep this question open to see if anybody knows how I just did that.


Here's an attempt at trying to figure out what happened.

When you push a new gitosis.conf to the server, it updates a locally checked out version in the gitosis-admin directory. Its possible that, due to some unknown reason, this file did not get updated correctly. Hence, the original repositories were working fine, while the new one was not. Then, when you pushed the loglevel change, the configuration was updated correctly.

You can always check to see what the current gitosis configuration is by looking at the /srv/gitosis/.gitosis.conf symlink, so if you run into this issue again, I would recommend checking the config first.

  • Its not an 'unknown reason', the install script is broken and the repo hook doesn't get set as executable. Mar 20 '11 at 23:53
  • @Arrowmaster I actually manually set the repo hook as executable :)
    – teuneboon
    Mar 20 '11 at 23:56
  • @Arrowmaster: By unknown reason, I mean, "I'm not telepathic and can't figure out which of a variety of reasons might have caused this after it was in working order." :)
    – Andrew M.
    Mar 21 '11 at 0:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.