I'm using Microsoft's Web Farm Framework, and I'm trying to use the Workflow features of version 2.0 to fire a custom command when 'Remove from Load Balancing' is selected.

Based on the linked article, I think I should be able to simply create my command using the Workflow Builder (currently I'm just testing with a simple mkdir c:\bob as my command), and then add ArrDisableLoadBalancing as a dependant.

This should [again I think!] mean that the command is fired immediately before ArrDisableLoadBalancing.

However this just does not work, the command itself is fine as I can use the 'Server Operations' option to fire it manually.

Does anyone have an ideas? There is very little literature on people successfully setting something like this up. So I fear I may have mis-read WFF's workflow capability.


Going to throw a couple of suggestions at you:

  • MKDIR is probably failing on all non-first-time attempts, meaning the dependants (i.e. the things that depend on success, you're right with your interpretation) won't fire - try a DIR instead, and check your WFF debug logs for an entry like "A subdirectory or file c:\yourdir already exists" - mkdir is possibly a bad command to lead with, without being wrapped in a nice, comfy batch file

  • ArrDisableLoadBalancing... I ran your example as a Server command, and instead used DisableLoadBalancing (i.e. without ARR on the front), and the server created a directory, then knocked itself out of load balancing. (edit: saw the action fire, but the server was slightly broken from an unexpected DHCP reallocation... might need some more work on this theory) But it only did it once; doing it a second time ran into the error above, which I'm going to RD my way through in a little while to check I'm not insane. (it's proof, I tell you). My guess is that Arr* might work only on the controller, while Enable/Disable might work on the servers themselves. Dunno, really.

  • And nope, at least one of those is probably wrong - I don't see the dependants fire after the first time. Interesting. – TristanK Mar 21 '11 at 11:40
  • Thanks so much, it was the 'ArrDisableLoadBalancing' that was causing the problem 'DisableLoadBalancing' works. Thanks – isNaN1247 Mar 21 '11 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.