2

I have a very large CSV file (24 MB) that I am trying to import using the import CSV from phpMyAdmin, however it always breaks down in the middle of import. What should I do to solve this?

The error I get is:

Error 101 (net::ERR_CONNECTION_RESET): Unknown error
2
  • Based on the answers in a different thread, this error might be related to the php driver for MySQL. serverfault.com/questions/74313 Mar 22 '11 at 18:42
  • If you're using XAMPP, check your error.log file (xampp\apache\logs\error.log) to see if there's any clues on the error you're getting. Nov 13 '19 at 18:36
3

The problem is probably caused by the timeout or the maximum filesize for PHP scripts on your server.

Try setting max_execution_time and max_input_time to a higher value. The configuration file options for maximum file sizes have already been mentioned by kenny.r.

2

You can increase the values for upload_max_filesize and post_max_size in your php.ini file.

This will allow you to upload the entire file, so that MySQL can properly process it.

4
  • +1, probably just choking on the large file size. Mar 22 '11 at 18:15
  • I actually tried setting the size to a large value and it still didn't work
    – EquinoX
    Mar 22 '11 at 18:29
  • Your upload speed might be too slow for your timeout value. Try joschi's suggestion. Mar 22 '11 at 18:34
  • I did change the max_execution_time to 4 minutes and even before 4 min it crashes
    – EquinoX
    Mar 22 '11 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.