How do you delete all partitions on a device from the command line on Linux (specifically Ubuntu)? I tried looking at fdisk, but it presents an interactive prompt. I'm looking for a single command, which I can give a device path (e.g. /dev/sda) and it'll delete the ext4, linux-swap, and whatever other partitions it finds. Essentially, this would be the same thing as if I were to open GParted, and manually select and delete all partitions. This seems fairly simple, but unfortunately, I haven't been able to find anything through Google.

9 Answers 9


Would this suffice?

dd if=/dev/zero of=/dev/sda bs=512 count=1 conv=notrunc
  • 7
    This will not delete the partitions. By deleting the partitions he meant to preserve the MBR and just empty the partition table. Mar 23, 2011 at 19:22
  • 3
    No, this appears to do exactly what I need. I don't really care if the data is still there. GParted shows that the partitions are gone after running this, and that's what I wanted.
    – Cerin
    Mar 24, 2011 at 11:53
  • 2
    Don't forget to unmount the driver, otherwise it won't work.
    – OrangeTux
    Dec 6, 2013 at 14:47
  • 1
    Is the conv=notrunc option really needed? See here.
    – Mmmh mmh
    May 18, 2019 at 21:30
  • 1
    To be fair, he said delete the partitions, not the partition table or data, so it wasn't really clear. But I think we knew he just wanted the parts not to register, which makes this the correct answer. To delete the data would be uneccesary. IF you want to zero it, thats a different story, that's deleting the data too. Aug 10, 2020 at 19:04

The wipefs program lets you easily delete the partition-table signature:

wipefs -a /dev/sda

From man wipefs

wipefs can erase filesystem, raid or partition-table signatures (magic strings) from the specified device to make the signatures invisible for libblkid.

wipefs does not erase the filesystem itself nor any other data from the device. When used without any options, wipefs lists all visible filesystems and the offsets of their basic signatures.

wipefs calls the BLKRRPART ioctl when it has erased a partition-table signature to inform the kernel about the change.


Quick and Dirty: use gparted to delete the partitions, or if you’re in a hurry:

dd if=/dev/zero of=/dev/[disk device] bs=512 count=1

This will zap the MBR of the drive (Data is still intact).


dd if=/dev/zero of=/dev/[disk device]

to wipe the whole drive (write a single pass of zeros over everything. Not "secure" but usually good enough), or use a "disk shredder" tool for a secure wipe.

  • 1
    why is the second "not secure"?
    – Herdsman
    Jul 11, 2020 at 8:54
  • Not secure because it's possible that the disk's contents could be partially recovered by someone with physical access to it. A secure wipe writes multiple passes of random data over the whole disk. Mar 16, 2021 at 20:51

Use improved non-interactive version of fdisk, which is sfdisk

To erase partition table use this command:

sfdisk --delete /dev/sda

Note: no confirmation will be thrown, the partitions will be deleted instantly and forever!

  • I think it's worth making it clear that after running this command there won't be any confirmation prompts whatsoever, the partition will be deleted instantly.
    – red-o-alf
    Sep 8, 2022 at 1:01
  • 1
    fair point, added
    – Suncatcher
    Sep 8, 2022 at 4:09

See man sfdisk, which is a non-interactive variant of fdisk. Other than that, you can delete the whole partition table with dd, as pk wrote.


You should be able to use parted for this aswell, although that may involve some scripting to loop through the partitions.

  • It may be worth to mention that e.g. parted /dev/mmcblk0 --script mklabel gpt deletes all existing partitions. For me it was parted /dev/mmcblk0 --script mklabel msdos
    – grenix
    Jan 28, 2022 at 11:30

If we're talking about MBR-style partitions...

dd if=/dev/zero of=/dev/[disk device] bs=1 count=64 seek=446 conv=notrunc



This standard command copies bytes from a source and writes them to a destination. It's the simplest flexible tool for this job.


Here, we specify that we're reading from /dev/zero, which is a special device which emits NUL bytes--zeros.

of=/dev/[disk device]

Here, we specify which device we're writing to.


dd thinks in terms of blocks. The default block size may be 512 bytes, 1024 bytes or 4096 bytes, depending on your system. However, we need to address things more precisely than that, so we tell dd to use a block size of 1 byte.


Here, we tell dd to write 64 blocks (or bytes, because of our bs=1 parameter), since the primary partition table consists of 4 16-byte partition entries, for a total of 64 bytes.


The primary partition table within the MBR (so, not talking about GPT here) is located 446 bytes in, so we instruct dd to seek 446 bytes in before writing.

Extended partitions are generally created by using a primary partition slot to point at the extended partition table, so if we erase the 4 primary partitions, we effectively wipe the extended partition table as well; the OS won't be able to find it, so it won't be able to read and interpret it. (If you want to wipe the extended partition table, you'll need to know more about the operating system; different operating systems do extended partitions in different ways.)


I wanted to do the same thing (except in Slackware 14.2) but found I could not effect most of the solutions proposed here, with the most elaborate and well-documented solution creating new problems for making replacement partitions. That deleted the partition but some partitioning software apparently found the partition backups automatically.

I found f3probe (http://oss.digirati.com.br/f3) solved the problem of deleting all the partitions, quickly and easily, working with large capacity drives, and created exactly 1 partition spanning the whole drive, which was easy to delete.

It was also easy, from there to create new partitions, in a straight-forward way.


f3probe --destructive --time-ops /dev/sdb
# Now we know only 1 partition exists on /dev/sdb
#    which is /dev/sdb1
# Unmount that partition
umount /dev/sdb1

# Delete that single partition
parted /dev/sdb rm 1

# Now you can create new partitions
# i.e. parted /dev/sdb mkpart primary fat32 1049K 15.8G
# Update /etc/fstab before rebooting....

Using gparted from petalinux on EMMC for me it was

parted /dev/mmcblk0 --script mklabel msdos

Here the corresponding help output

# parted /dev/mmcblk0 --script help mklabel      
  mklabel,mktable LABEL-TYPE               create a new disklabel[ 6897.473870]  mmcblk0:
 (partition table)

        LABEL-TYPE is one of: aix, amiga, bsd, dvh, gpt, mac, msdos, pc98, sun, loop

BTW: concerning wipefs -a /dev/sda (and maybe some other solutions here)

Using this made commands like parted /dev/mmcblk0 --script mkpart primary fat32 1MiB 2049MiB for me to fail with Error: /dev/mmcblk0: unrecognised disk label. The mklabel command of gparted is 'repairing' this condition resp. seems to be a good preparation for follwing steps.

See also https://unix.stackexchange.com/questions/200582/scripteable-gpt-partitions-using-parted

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .