We've noticed an issue on machines we've updated to Windows 7 SP1 accessing mapped drives as an administrator. UAC is enabled, and it appears to be specific to a process or command prompt running as administrator.

Say for a drive M:, mapped to \\foo\\bar

If we run a standard command prompt and type "dir M:" normally (non-admin), it works fine. If it's from an admin command prompt, it now receives "The system cannot find the path specified.". Yet from the same admin prompt, dir "\\foo\bar" works fine - it is only the mapped drive letter that fails.

Whether the share is read-only or read-write does not appear to matter. Further info has shown that it was not whether the account was an "owner" of the share (think homedrive) that mattered, but how/when it was mapped.

As for why the command prompt is running as admin - that is because it's a developer environment for compiling software and it needs admin in order to register DLLs. It's also common when debugging...

Additional Info:

We've been on Windows 7 for a while. I'm surprised this worked at all, given the link @pk provided. The shares in question are mapped during login...so it working/not working may be tied to that.


If you elevate a command prompt, you will no longer see any local namespace mapped drives created from your original login (whether created through a logon script, WNetAddConnection, or otherwise).


  • Great link, thanks. I would expect this same behavior to have occurred in Windows 7 prior to SP1 though...the workflow has been happening on Windows 7 for quite some time. – Joshua McKinnon Mar 23 '11 at 15:22
  • That is strange and I don't have an explanation for it. Did you change your UAC settings? – pk. Mar 23 '11 at 15:24
  • No changes... Both my workstation and the user that reported it have been on the Default UAC setting since day 1 (for me well over a year) – Joshua McKinnon Mar 23 '11 at 15:35
  • I am accepting your answer, since further investigation showed Windows 7 pre-SP1 did not have "EnableLinkedConnections" set, and this does explain the behavior. Still not sure why user had it working previously, they must have mapped drive as admin at some point and forgotten. – Joshua McKinnon Mar 25 '11 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.