1

I have a Windows Server 2003 running from a Vmware player on Win 7 box. The idea is to test Windows Deployment service in the virtual network. Is it possible to configure the vmware dhcp server with WDS related stuff(option 66, 67)? I found a few references where people were using the vnetlib.exe to start, stop the dhcp serverchange the subnet mask etc - but there's no info on how to get set the dhcp server options.

DHCP config from the virtual network editor

I do have the Workstation, without the license for it. In the Virtual network Editor, the DHCP settings for the network I'm using, only allows me to set the subnetmask, IP ranges and stuff like that. But not the dhcp options.

DHCP server on the WDS server Authorizing the DHCP server in the guest WDS server fails. The VMware player can run its own dhcp server fro the virtual network with out any authorization from the Active directory - can I do the same, with Win dhcp server in the guest Win Server?

~~~~~

Can I authorize W2K8 DHCP server for private network, even when prohibited in enterprise network? says we have to run a third party dhcp server... :/.

  • @MarkM: That makes total sense! Thanks for pointing it out ... – Tathagata Mar 24 '11 at 1:24
2

Why not just run DHCP on the WDS server? This will more accurately reflect a live environment anyway.

|improve this answer|||||
  • Actually I failed at that ... When I turn off the Vmware dhcp service from the host Win 7 box, and start dhcp one on the WDS on Win Server 2003, I can not do network boot for some weird reason. There are just no dhcp offers in the network from the WDS-DHCP. So I decided to go this way. But thats a different issue altogether. But the more relevant reason is administrative. We (a small lab) are just renting the virtual server and the DHCP is served by the Networks team for the entire University. – Tathagata Mar 24 '11 at 1:59
  • tried out running the DHCP in the guest Win server WDS again, but it fails to authorized. – Tathagata Mar 24 '11 at 15:08
1

If your deployment server is also your DHCP server, PXE uses the same port as DHCP (67) and therefore you need to enable option 60 in DHCP options so that your server will listen on port 4011 for PXE requests. Don't forget to open 4011 up on your firewall as well.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.