2

I am trying to delete folders through webdav but all I get is 403 on the client and "Directory index forbidden by Options directive" in the Apache error log. I enabled "options indexes" for the folder and I stopped getting the errors in either the client or the log, but I still can't rename or delete folders through webdav.

Any ideas why I'm unable to edit folders through webdav?

I am running WAMP, default installation with Apache 2.2.17. I can connect, create files, delete files, rename them, etc. I can create folders but not delete them or rename them, once they're created.

On the access log, whenever I try to delete, I get this: "DELETE /uploads/shahs HTTP/1.1" 301 243

On the error log, I get: Directory index forbidden by Options directive:

The Webdav client gives a 403 when trying to delete or rename folders.

Once, I added "options indexes," I stopped getting the error message in the Apache error log and the 403 on the webdav client, but now, deleting or renaming does nothing. No error messages, but nothing happens, at all.

1

I had the same Directory index forbidden by Options directive error in the Apache "error_log", and corrected it by editing "httpd-dav.conf" and adding the line :

Options Indexes FollowSymLinks

in this context :

<Directory "/absolute/path/to/my/fancy/directory">
  Dav On

  Options Indexes FollowSymLinks
  Order Allow,Deny
  Allow from all

  AuthType ...

After that, no more errors.

0

Incorrect local filesystem permissions? Apache WebDAV misconfiguration? SELinux? Filesystem mounted read-only? Unfavorable phase of the moon?

Without more information about your web server configuration, it's hard to provide more targeted advice. Is there anything helpful in your Apache access or error logs, or in the syslog?

  • Thanks a lot for your quick reply. I added more information to the original post. I hope it helps. – sandwiches Mar 25 '11 at 14:44
0

Turns out the requests like DELETE /uploads/shahs are not exactly correct and should have a trailing slash DELETE /uploads/shahs/ or at least Apache thinks so. To make Apache accept your webdav client you may add line SetEnv redirect-carefully 1 to your httpd.conf, like that:

<Directory "/mywebdav">
    SetEnv redirect-carefully 1
    Dav On
</Directory>

Still actual for Apache 2.4 and KDE5.

Sources: http://support.sas.com/rnd/javadoc/93/Foundation/index.html?com/sas/services/webdav/package-summary.html https://github.com/lookfirst/sardine/issues/119

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.