This small but really annoying thing worked well on the Windows Server 2003 machines. After upgraded to 2008 and it's new flawless Scheduler, the scheduled Console Applications are running in hidden mode.

I can't for my life find out, even with google other that have same problem? Every task has a "hide this" option that i Of Course has unticked - because I want it visible :). But the scheduler keeps hiding it ;). The console window has important output-logging which works fine if it rans manually.

  • the scheduled Console Applications are running in hidden mode. Do you remember what you meant by that statement? Unlike shortcuts, the Task Scheduler does not have any options to control the display of tasks when they are run. (If you meant the Hidden checkbox, that has nothing to do with the program, it controls whether the task is shown in the Task Scheduler or not.)
    – Synetech
    Oct 2, 2015 at 20:50

5 Answers 5


This isn't possible anymore: services are run on a different desktop than users, and this affects the Task Scheduler as well. More info: http://blogs.technet.com/b/askperf/archive/2007/04/27/application-compatibility-session-0-isolation.aspx

What I'd suggest is that the scheduled tasks pipe the output to a log file, e.g. instead of abcd.exe, abcd.exe > c:\logs\abcdlog.txt

  • Wow, that's was a clear and accurate answer. Thank's for the link. I'm surprised though that the Scheduler can't imitate "run as user" when a user account is selected for permissions to run. Mar 28, 2011 at 8:05
  • 1
    I haven't checked on Windows Server, but on Windows 10 it's possible to run with a visible GUI by choosing "Run only when user is logged on" in the task's General tab. For the "At log on" trigger you also need to set "Delay task for" to something long enough, otherwise the program runs without GUI in session 0.
    – CrouZ
    Feb 22, 2020 at 21:57

I discovered that a task has to be set for "run only when user is logged in" to be visible. Otherwise it is hidden (regardless of the setting of the "Hidden" checkbox).

  • For my task with the "At log on" trigger I also had to set "Delay task for" to something long enough, otherwise the program still ran without GUI in session 0.
    – CrouZ
    Feb 22, 2020 at 21:59

Did you try using 'Process Explorer'. It's very powerful and very very useful. You may find what you are looking for in that tool.

  • Thank's. This is not really my topic (I still need the scheduled prompt to running visible) and are not worth a negative vote. I vote up ur answer to zero because process explorer indeed IS a useful tool in this topic. However you also get an accept if you find an answer of the problem :). Mar 11, 2011 at 14:14

This is just a side note when running task scheduler.

  • Enable administrator in elevated cmd prompt:net user administrator password /active:yes

  • Log in to Administrator accout first (you can log back to your normal account afterwards.

  • Create a task, run as (Administrator) Run with Highest Priveleges

  • Create your tasks as bat file first and run as Administrator

  • Copy the command into the Scheduled task after you are sure it runs correctly

  • Or call for the bat file to run.


A simple, native Windows solution to this problem is to change the logon options for the task under 'General / Security Options' to 'Run whether user is logged on or not'.

For reasons which I believe are related to a holdover from WAAAAY back in NT days, this then allows the 'Hidden' option to work correctly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .