3

My setup is a bit awkward. I've got http://sub.main.com mapped to my server's IP but not the http://main.com. I am running two sites on my server(using different web frameworks). For each of those sites I've got virtual hosts configured in default site, which looks something like this.

<VirtualHost *:80>
    ServerAdmin webmaster@localhost

    ServerName "sub.main.com"
    DocumentRoot "/var/www"
    ....
</VirtualHost>

<VirtualHost *:80>
    ServerName appsphere.djangoserver
    Alias /media /srv/www/appsphere/media/
    ......
    ......
    WSGIScriptAlias / /srv/www/appsphere/apache/django.wsgi

</VirtualHost>

Now how can I make my second virtual host a subdirectory/subdomain of first virtual host. I want to access the second site using http://sub.main.com/appsphere

2

Change your first VirtualHost declaration to the following:

<VirtualHost *:80>
    ServerAdmin webmaster@localhost

    ServerName "sub.main.com"
    DocumentRoot "/var/www"

    Alias /appsphere/media /srv/www/appsphere/media
    WSGIScriptAlias /appsphere /srv/www/appsphere/apache/django.wsgi

</VirtualHost>
| improve this answer | |
  • Thanks, it worked. I needed to change the /media settings in second virtual host to /appsphere/media, but rest was a breeze. – Neo Mar 27 '11 at 4:50
0

It should be as simple as adding a few lines to your first VirtualHost:

<VirtualHost *:80>
    ServerAdmin webmaster@localhost

    ServerName "sub.main.com"
    DocumentRoot "/var/www"

    Alias /appsphere/media /srv/www/appsphere/media/
    ......
    ......
    WSGIScriptAlias /appsphere /srv/www/appsphere/apache/django.wsgi
</VirtualHost>

I don't know what you have in the "......." section that may need updating to reflect the path change as well.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.