We have a Zabbix Server 1.8.2 running on an Debian VM - installed from the repositories of Squeeze. Also, we are installing Zabbix 1.8.2 agents in various other VMs, most of them running Debian, installed through apt-get, too.

Once we installed the agent in the host and create the corresponding host in server, we cannot make the server collect info from the agent if the monitored host does support IPv6. If we disable IPv6 on the monitored host, the agent works well and the server monitors it flawlessly.

The question is: why does this happen? Is there another way to avoid this problem? There has some way of "disabling IPv6" out of Zabbix agent?

Thanks in advance!

2 Answers 2


Hard to say why this might be happening without some more debugging information. Some questions and commands that will help people better troubleshoot:

  • Are you disabling IPv6 on just the agent host or both the agent and the server?
  • If only the agent, is IPv6 running on the server?
  • Are the server and agent hosts within the same subnet or do they route between each other?
  • When IPv6 is enabled, are you configuring a static address or using the automatic neighbor detection?

With IPv6 enabled, run the following commands as root on the server and client and post the output here.

ifconfig -a
netstat -anp
route -n
cat /etc/hosts

It could be something simple like the hostname of the machines resolving to the IPv6 address when IPv6 is enabled but it is not able to route between each other using the IPv6 address. This information would help me and likely others figure out what is happening.

  • We found a possible root cause for the probem: our name server does not support IPv6 and we believe the reverse DNS does not work given that. Is it possible? How could we solve the problem in this case (without disabling IPv6 in all machines or enabling IPv6 in DNS)?
    – brandizzi
    Mar 30, 2011 at 20:50
  • How are you checking this? Are you trying to ping the zabbix server hostname with IPv6 enabled and it fails to resolve? Reverse DNS shouldn't affect zabbix operation. But forward DNS would if you are using hostnames. You could probably test this by enabling IPv6 and then trying to poll the agent and communicate to the zabbix server with only IP address and not hostnames.
    – Andy Shinn
    Mar 31, 2011 at 0:59

This was a bug in zabbix_agentd that was fixed in 1.8.5.

This will be available in wheezy. It's been proposed for squeeze-backports, though nothing has happened so far.

If you can't update, you can work around it by specifically setting the ListenIP directive to your exact IPv4 address, for example:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.