I have MS SQL Server Express running on Windows Server (both AMD64, 2008 R2). MSSQL is configured for remote access. This access works fine when I disable the firewall entirely. It stops working when I enable the firewall.

I've read and tried instructions from these Microsoft articles: here here

I've added both TCP and UDP incoming exceptions on the server for the port used (set to 3306) and for the executable: C:\Program Files\Microsoft SQL Server\MSSQL10_50.SQLEXPRESS\MSSQL\Binn\sqlservr.exe I've set the firewall rules to apply to all domains. Still, no connection.

Nothing fancy here: No ActiveDirectory, no domain, no layer 3 switching, just a simple SQL Server Authentication connection from a workstation connected to the same physical switch as the server.

Aside from disabling the firewall, does anyone know how to fix this?


Port 3306 if for mySQL.

Ports 1433 and 1434 are for MS SQL server. I would advice you to configure your firewall to allow traffic for TCP/UDP on these ports.

| improve this answer | |
  • I set MS SQL to use port 3306 to slightly confuse potential blackhats for a few extra seconds (No MySQL used). In any case, I read the first article I linked to as implying that opening 1434 was not necessary in my case. Turns out it was -- that did it. Easy green check for you :) – Charles Burns Mar 27 '11 at 4:44
  • The SQL Browser is required when ever there are named instances in use. It is recommended to leave them as dynamic IPs so that if the static port that you selected isn't available SQL won't pick that port. With static IPs if the port is in use when SQL starts it can't grab the port and won't retry grabbing it later. – mrdenny Mar 27 '11 at 5:39

Had the same: when Windows Firewall (Windows 2012 R2 Standard) was disabled - I could not access remotely my SQL Server 2014 Express. I added FW exception: for application and for TCP 1433. And I eneabled in SQL configuraiton TC connections and named pipes. But nothing happened... Until I added to Windows Firewall next rule with 1433 UDP port... And it suddenly started to work !

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.