I'm porting some old ASP/.Net applications over to a clean build of w2k8R2 running IIS7. The older .Net applications and some 3rd-party dlls require enabling 32-bit mode for the applications pools they run in. When I do this, error pages (both custom and detailed) disappear.

The correct error status is returned to a browser, but there is no content - just a blank page. This happens regardless of the custom/detailed local/remote Feature Settings for error pages and regardless of whether a local or remote browser is used. No errors are thrown that I can detect, just no content in the pages.

The fact that I can't find any references to this problem anywhere lead to suspect that it's a problem I've introduced earlier in the build. I can't see how, though.

Has anyone experienced anything similar?

  • Just to clarify: this behaviour is nothing to do with the applications themselves. I see the same behaviour with the default website before I've added any additional sites. – Benjamin Priestman Mar 28 '11 at 13:45
  • would be useful to see your web.config asp.net and iis custom errors sections – Kev Mar 28 '11 at 14:16

I'd not taken my build back far enough. The culprit turned out to be an old GAHelper.dll that I'd ported over from the old configuration. It doesn't seem to play nicely with IIS7. We use it on most of these sites, so I had added it as an ISAPI filter at the top level. Removing it allows errors to display as expected.


Try setting the existingResponse="PassThrough" attribute in your web.config:

    <httpErrors existingResponse="PassThrough" />
  • If I've got it right, I'd set this attribute if I was seeing IIS custom errors instead of my own. My problem is that is that I'm not seeing any content in the response at all. I've tried it anyway. It makes no difference. – Benjamin Priestman Mar 28 '11 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.