Good day to you.

I have net-snmp- on recent gentoo host, there's an extension to snmpd configuration, like :

   exec dashboard-hlpdesk-login /opt/server/bin/hlpdesk-login.sh
   exec dashboard-radius-login /opt/server/bin/radius-login.sh

Fetching values by MIB or OID is fine except when I run

snmpwalk  -v2c -c public localhost NET-SNMP-EXTEND-MIB::nsExtendOutput1Table
Timeout: No Response from localhost

That timeout seems random.

And that also affects fetching single extended oids either with snmpget or snmpwalk, fetching freezes for several seconds and then works again.

P.S. I've also tried it on recent Debian Squeeze, same.

  • One of extend cmds take 1-5sec to complete. – Dima Medvedev Mar 29 '11 at 13:42

By default the timeout for snmpwalk is really really short(I've seen implementations where it is set to 300ms by default). Try:

# snmpwalk -t 20 ...

(or whatever the timeout value is for the version of snmpwalk you are using)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.