I have a 2008 server that is the print server. I support Windows 7 clients that are mapping printers by Group Policy preferences. I have it as a user preference (because computer policies don't have the "set as default" option). Then I have the policy loopback process in the section Computer > Administrative Templates > System > Group Policy

When I log on as a user, I dont get the printer mapped. However if I run gpupdate /force the printer appears. So it appears that the group policy is functioning correctly - apart from somehow not being applied at startup.

I am running a 3rd party app called Deep Freeze which is like a double edged sword: It's good for keeping end user tampering at bay, but bad for management. Does anyone know any issues that come about from combining Deep Freeze and Group Policy? Is there some way I can check why this group policy is not being applied at startup?

I should also add that I have another group policy that allows users to install drivers Point and shoot to two print servers in the network.

3 Answers 3


Having JUST left an academic environment where we were ghosting 1200+ workstations each quarter and needed to keep University students from hacking them to smithereens, I feel your pain. As it happens I spent September through January hacking on that exact problem. I did not find a complete answer, but I did find out some things that helped:

  • Nearly all problems are a result of setting up the default user profile for use by students.
  • Machines that are properly sysprepped experience this problem a lot less often than profile-copy methods.
  • When it happens, sometimes the access to the print server is actually the ghost-user or the profile-copy user, or some other cached credential on the image rather than the logged in user.
    • Jason Berg's delay method will make this work if this is what's nailing you. By the time the GPO fires, profile setup is completed and these cached-user accesses won't happen.
  • Sometimes, going into the Options on the Preference and hard specifying "Run with user's permissions" make it work more often.
  • This seems to rarely happen when the profile exists on the machine, such as happens when troubleshooting the problem :P. I haven't used Deep Freeze, so don't know if it leaves profiles behind after a login.
  • Sometimes Deploying the printer to the user and also setting a GPO Preference to set the default printer works more reliably than Deploying to the computer. You're using loopback processing anyway, may as well just put everything in the User GPO that you can.

And I still didn't get it completely knocked down. It's a tough problem.

  • All the devices are sysprepped properly and default profile is part of the sysprep too using <copy profile> in unattend as per microsoft best practice. But thats for the comments. and is is quite a random issue.
    – JohnyV
    Commented Mar 30, 2011 at 2:45
  • @JohnyV It was quite random for me too. Made it hard to hunt. If your users can live without printers immediately at login, Jason's idea is worth trying. We couldn't do that since our login script is GPO based, and it needs to fire fast at login.
    – sysadmin1138
    Commented Mar 30, 2011 at 2:50

Windows Vista and 7 don't process group policies at startup all that well. I usually set the following policy to 120 and it fixes all of my problems. Try that out and see if it works:

Computer Configuration/Policies/Administrative Templates/System/Group Policy/Startup Policy Processing Wait Time

  • Tried this still had the same issue. But I want aware of this policy ill keep it mind.Thanks
    – JohnyV
    Commented Mar 30, 2011 at 4:30

In addition to what sysadmin1138 and Jason have answered, I'm wondering if enabling the "Always wait for the network at computer startup and logon" GPO setting might help here.

  • Tried this also. Still had the same problem. Thanks
    – JohnyV
    Commented Mar 30, 2011 at 4:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .