I scrutinized every single article that there is on the web for this one but NO JOY! I am getting the infamous error 500 after that I have installed internet explorer 9. Here is a detailed step of what I had done....

STEP 1 - Installed PHP using Web Platform installer , IIS 7 on Windows 7 x64 STEP 2 - Configured PHP.ini to display_errors so I turned that on STEP 3 - With IE8 EVERYTHING was showing up fine .... STEP 4 - When I installed IE9 .... the error 500 message came back STEP 5 - Looked into php.ini and my original settings are all still there STEP 6 - reset iis7 with iisrestart from command prompt....

Help would be much appreciated! What is wrong?

Regards Sandy

  • IIS on remote host? Try requesting the page on server browser (localhost). If ok, it's an IIS setting (config editor / system.webserver/httpErrors/errorMode: change to detailed – user65297 Oct 4 '12 at 6:40

It's probably the IE Friendly Error Pages (which aren't friendly at all). Here's how to disable them: http://blogs.msdn.com/b/ieinternals/archive/2010/08/19/http-error-pages-in-internet-explorer.aspx.

It's possible that you turned off that setting already in your IE8 instance.

As a side, there may be additional information that you can pass through for PHP. Previous question

c:\windows\system32\inetsrv\appcmd.exe set config "{sitename}" -section:system.webServer/httpErrors /existingResponse:"PassThrough" /commit:apphost
  • As Scott mentioned, it sounds like friendly error pages, but have you tested with other browsers like Firefox, Safari, Chrome, etc. and receive the same results or are the other browsers displaying the errors correctly? – bmurtagh Nov 5 '12 at 0:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.