I'm trying to rename a server in a domain which has already given me a few problems. Since a long time i cannot ping the hostname of it from another computer in the domain.

The DC is a Windows Server 2008 R2 and the computer with the problem is a Windows Server 2003 R2.

I tried to run Winsockxpfix, added the WINS server changed the IP, deleted the computer in the DC and re attached it. Removed the computer from the domain and joined a workgroup and re tried to join it in the domain, but can't seem to figure it out.

The message of the error when trying to rename it is:

The following error occurred attempting to rename the computer XXX. The network path was not found.

  • Can you ping your domain name and DC by name? – HostBits Mar 31 '11 at 16:51

try deleting and re-adding the network adaptor and then see if you can rejoin the server to the domain. You should not need wins resolution for this. Verify that you can perform an NSlookup from the 2003 server if you have name resolution issues


Take it out of the domain, rename it and get in back in the domain again


delete the computer account in the domain, (also delete any dead computer accounts that are same as the new name), then disjoin the machine frm the domain, reboot the machine and add it again, reboot the machine again. This worked for me few months ago!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.