I am trying to move an application from windows server 2003 R2 to Server 2008 R2. It uses MVC 1.0 and to make it work I added a wildcard handler and then unchecked the "check file exists" to make the app work.

In Server 2008 I've tried running in classic and integrated modes and I cannot get anything other than the root page of the site to load. The URL rewriting just isn't working for anything and I get a 404 error.

I don't know my way round IIS 7.5 so I really don't know where to look to try and debug why I get the 404 and why the URL Rewriting is failing.


The handlers are different in IIS7 than IIS6. You don't need to add the wildcard handler as long as .NET was already installed. I assume that was for aspnet_isapi.dll that you're trying to add.

You should be able to remove that and make sure that just .NET is installed. To re-register .NET you can run aspnet_regiis -i from the framework folder(s).

Make sure that the MVC 1.0 install worked, but that will simply register it in the GAC which your ASP.NET app can call directly. IIS doesn't have (or need to have) any awareness of MVC.

And, you want to make sure that .NET works. At the top level of IIS, go to the ISAPI extensions and ensure that your framework version is enabled. That can cause a 404.

Then try testing a simple hello world for a test.aspx page. Once you have that working, then move forward from there.

  • All that is working. The root web page works (server/app). However every page that should work from there, including the default page's view (server/app/overview) returns a 404 – Spence Apr 1 '11 at 5:39
  • Is it the extensionless pages that don't work? If so there is a hotfix that may be what you need. support.microsoft.com/kb/980368 – Scott Forsyth - MVP Apr 1 '11 at 14:33
  • Thanks for trying. The Hotfix still hasn't resolved the issue. – Spence Apr 4 '11 at 1:26
  • Issue was a PEBKAC. The app was referring its URLs to the root of the website, not to the root of its virtual directory. I debugged the log file and picked this up, once I moved it to the root everything worked. – Spence Apr 4 '11 at 1:40
  • Ah, glad you got it figured. – Scott Forsyth - MVP Apr 4 '11 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.