6

I'm logging into a Windows 2003 system from a Windows 7 workstation using Remote Desktop. I'm aiming to try and copy some files to the server from the client. In the 'local resources' section of the RDC, I've got all the drives ticked so it should be sharing those drives with the remote server.

However, when I log in, none of these shares get mapped, and if I navigate to \\tsclient, I just get a blank listing.

What's wrong here? What do I need to enable to allow this functionality to work?

1
  • 1
    I've found RDP sometimes just does that, no reason, no idea why, check for firewalls I guess otherwise reboot your client, if that's no good it might need a server reboot.
    – Chopper3
    Apr 1, 2011 at 10:19

4 Answers 4

6

Is there any kind of restrictions on the server that you are remoting into?

Check: Start > Run > tscc.msc

Right click on RDP-Tcp and go to Properties > Client Settings

Make sure that Drive Mapping doesn't have a check in it.

1
  • 5
    tscc.msc works on Server 2003. But what's the equivalent of tscc.msc on Server 2012?
    – Pacerier
    Mar 13, 2015 at 16:38
2

If I understand correctly, this can happen if drive redirection is disabled. To see if that's the case on Windows Server 2012 R2:

  1. Run mmc.
  2. Under File, choose Add/Remove Snap-In.
  3. Add the Resultant Set of Policy (RSoP) snap-in.
  4. Right-click on Resultant Set of Policy and choose "Generate RSoP Data."
  5. Choose logging mode and follow the on-screen prompts to select the computer you're interested in. You don't need user policy settings.
  6. Navigate to Computer Configuration, Administrative Templates, Windows Components, Remote Desktop Services, Remote Desktop Session Host, Device and Resource Redirection.
  7. Check whether "Do not allow drive redirection" is listed as Enabled.
1

On Windows Server 2008 R2:

Server Manager > Remote Desktop Services > RD Session Host Configuration

Right click on RDP-Tcp Connection and choose Properties.

Click on Client Settings tab.

Clear Drive Mapping checkbox in list of disabled settings.

0
  • If files AND text (eg entire clipboard) isn't working, kill and restart rdpclip.exe on the server
  • If text copy/paste works, but file transfer doesn't, definitely could be the "drive redirection" feature being disabled. Another way of checking that is:
  1. gpedit.msc (local group policy editor)

  2. Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection

  3. Disable Do not allow drive redirection

  4. Re-establish the RDP connection

enter image description here

This policy setting specifies whether to prevent the mapping of client drives in a Remote Desktop Services session (drive redirection).

By default, an RD Session Host server maps client drives automatically upon connection. Mapped drives appear in the session folder tree in File Explorer or Computer in the format on . You can use this policy setting to override this behavior.

If you enable this policy setting, client drive redirection is not allowed in Remote Desktop Services sessions, and Clipboard file copy redirection is not allowed on computers running Windows Server 2003, Windows 8, and Windows XP.

If you disable this policy setting, client drive redirection is always allowed. In addition, Clipboard file copy redirection is always allowed if Clipboard redirection is allowed.

If you do not configure this policy setting, client drive redirection and Clipboard file copy redirection are not specified at the Group Policy level.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.