2

I have a scheduler task setup to run every hour, to update a web server. It runs each hour correctly. But after a reboot, the task always starts to fail: The error is:

  Task Scheduler failed to start "\Website Refresh" task for user "myserver\Admin". Additional Data: Error Value: 2147943726.

The task requires admin privileges and is setup like this:

  • "When running the task, use the following user account" (myserver\Admin)
  • "Run whether user is logged on or not" (checked)
  • "Do not store password" (unchecked)
  • "Run with highest privileges" (checked)
  • "Hidden" (unchecked)
  • "Trigger" (daily at 12:00 AM ever day, after triggered repeat every 1 hour for a duration of 1 hour...")

This tasks fails the same way if I run it manually (using the RUN button in the task scheduler).

Once I go in as admin and reset the password on the task it starts work again. Until I reboot again.

2 Answers 2

1

According to several forum posts I found, there seems to be a Vista problem with storing User credentials for the task scheduler.

Symptom (eventlog):

  • Event ID: 101
  • OP Code: 6619136
  • Error Value: 2147943726

Possible Solution:

If the "Run whether user is logged on or not" option is used:

  • check the box on "Do not store password"
  • check "Run at highest privileges"
  • make sure you got sufficient Admin rights for what your tasking.
3
  • I am already configured as indicated in the "possible solution", but it loses setting again after reboot.
    – jm.
    Jun 18, 2009 at 14:05
  • According to your original question, you have the "Do not store password" box UNchecked. Did you try it with it checked? Jun 18, 2009 at 14:37
  • I think this is the key: check the box on "Do not store password"
    – jm.
    Jun 23, 2009 at 14:24
1

"Trigger" (daily at 12:00 AM ever day, after triggered repeat every 1 hour for a duration of 1 hour...")

Doesn't this make it run only once a day? Duration should be 24 hours.

1
  • no, it runs hourly. But, in any case, I get the error even if I go and run it manually.
    – jm.
    Jun 14, 2009 at 19:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .