A few days ago the internal interface on one of my backup servers went down, and I've not been able to get it to work correctly since. In dmesg, I'm seeing:

ADDRCONF(NETDEV_UP): eth0: link is not ready
bnx2: eth0 NIC Copper Link is Up, 1000 Mbps full duplex
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
bnx2: eth1: using MSI
ADDRCONF(NETDEV_UP): eth1: link is not ready
bnx2: eth1 NIC Copper Link is Up, 1000 Mbps full duplex
ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
eth0: no IPv6 routers present
bnx2: eth1 NIC Copper Link is Down
eth1: no IPv6 routers present

eth0 is working correctly as before, but eth1 appears to connect, come up and then drop pretty much straight afterwards. On the first visit out to the data centre plugging in a new ethernet cable appeared to temporarily correct the problem, but since then it's occurred again and now happens consistently.

I've tried:

  • Swapping switch ports (thinking it may have been a dead/dieing port on this Cisco 2960)
  • Swapping in a new cable, but still doesn't work, and both cables work correctly in my test laptop.

Could this be a software issue?? Any other ideas?

Edit: Further information

My /etc/sysconfig/network-scripts/ifcfg-eth1 looks like:

# Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet
#ETHTOOL_OPTS="autoneg on"

(I've since commented out the ETHTOOL_OPTS="autoneg on" for testing)

Update: I had a test switch in the rack (consumer gigabit Netgear) which we use for the internal DRAC network management network. Plugging this into the local switch and then into the server yields:

eth1: no IPv6 routers present
bnx2: eth1 NIC Copper Link is Up, 100 Mbps full duplex, receive & transmit flow control ON

It's not gigabit, but appears to be working perfectly. (not concerned with the network speed at this time). However how would I go about debugging an issue like this, the server is no different than the 20 other Poweredge 2950's we've got in there, all with the same configuration and still working correctly. The only time I'd seen an issue like thsi is connecting the DRAC cards to the Cisco 2950's (they refused to auto negotiate too).

Could this be a failing NIC, that's now not auto negotiating properly or is there something I should be checking on the system itself which may be messing it up?

  • Are you hard wiring the speed/duplex/neg settings with ethtool ? – Jonathan Ross Apr 4 '11 at 10:10
  • Hi Jonathan (see above, more info added) – kwiksand Apr 4 '11 at 11:22

Thanks for the info. You seem to have run through the cabling and switchport swapovers which would eliminate all the physical elements barring the NIC being faulty itself.

If you've tried hardwiring the link at both ends with ethtool at the 10full, 100full etc with no flow control or autoneg then there's not too much else to try.

Two things spring to mind:

Buy a USB NIC and connect it to the switch (they're a pound plus delivery USB NICs (really!) get the 0.5m USB extender so it can rack mount cleanly). You'll only get 100Mbps out of it but it's a good failover if your NIC has given up the ghost. They use the Pegasus drivers and work out the box on Debian and Ubuntu if that helps.

Secondly install ethtool if it's isn't already and run "ethtool -S eth1" for a full report on stats.

I'd stick with the USB NIC and put it down to a failing NIC if there's no other errors and you can't get any more debugging info.

  • Thanks again, I've not got any further though unforunately, a friend mentioned he'd had an issue with the Broadcomm drivers that were apparently fixed in a later kernel version, but as we've seen, the other 19 2950's in the server all have the same hardware/setup. The only thing i can think of is that the card has faltered over time and isn't liking the auto negotiation from the switch. – kwiksand Apr 5 '11 at 15:36
  • No problem. The USB NIC is a good backup. NICs do fail like most components. Bear in mind unless all your Servers came off the production line at exactly the same time there can be big differences amongst the same models of hardware. Updating kernels and building NIC modules is a good plan. – Jonathan Ross Apr 5 '11 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.