0

I have the following facts:

  • Exchange Server 2003
  • Different Outlook clients (2003, 2007, 2010)
  • Windows 2003 domain
  • Users are added to an account with 'send as' rights. (all people do have exactly the same rights on that account)
  • Some of them can mail using the account's emailaddress as 'From'.
  • Some of them cannot mail. They receive a non-delivery-report:

You do not have appropriate permissions to send e-mail to send to this recipient. For more information contact your system administrator

Any ideas on what is causing this?

Update: I also restarted the Exchange Information Store to reload the new account data from AD.

  • Are all the users sending to the same address? What's the error code on the NDR? Do you see this error across Outlook clients, or is it from just one type? – Holocryptic Apr 5 '11 at 13:04
  • 1
    How long has it been since you added the Send As permission for the affected users? – joeqwerty Apr 5 '11 at 13:25
  • Do you have multiple sites with DCs and users to which you trying to assign permissions located in different locations in the world? I would suggest running DCDIAG & NETDIAG on one of the DCs. – Vick Vega Apr 5 '11 at 13:55
  • @Vick Vega, this is just one DC on one location – jao Apr 5 '11 at 14:04
  • @joeqwerty We waited minutes, hours and days and we restarted the Exchange Information Store after every change. – jao Apr 5 '11 at 14:05
1

Take a look at this KB and apply the appropriate hotfix if applicable.

| improve this answer | |
  • The hotfix does not apply to our setup since we're using Exchange 2003 – jao Apr 6 '11 at 10:09
  • @jao "You are running Exchange Server 2003 SP2 together with a Store.exe file version that is equal to or later than version 7650.23. Version 7650.23 was first made available in the following Microsoft Knowledge Base article: 895949 “Send As” permission behavior change in Exchange 2003" – Holocryptic Apr 6 '11 at 10:37
  • Double check the KB, and check your store version. – Holocryptic Apr 6 '11 at 10:37
  • I'm sorry. I requested the hotfix and will apply it asap and let you know if it worked. – jao Apr 7 '11 at 9:39
  • I contacted Microsoft to get the hotfix, but they send me the wrong version (for servicepack 1, I have service pack 2). When I called them back to get the right version, I was told that they needed to create a 'call' and they needed my access ID. Quite strange, but I will call them back again and request the SP 2 Hotfix and let you know if it helped – jao Apr 9 '11 at 19:35
0

I'm going to add this as a second answer, because I don't want it to get confused with my previous answer.

I just ran into this (Ironic, I know). There's some hangup setting the Send As permissions from the server side. When I create a new user, I don't have the problem, but older established ones do have it.

I logged in as the user people want to send as, then assign delegate control via Outlook. Tested and it worked.

| improve this answer | |
  • good one, we'll try that as well – jao Apr 15 '11 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.