My Ubuntu 10.10 on my laptop Lenovo T400 lost its wireless connection, and couldn't detect the available wireless networks, while being in the middle of working.

This happended before and my solution was to reboot my OS. But now I am in the middle of working, and would like to find a way without reboot. In NetworkManager applet 0.8.1, disabling and then enabling Networking does not work. So I then followed Wireless troubleshooting.

First, I ran the following command, which says my wlan0 is "Disabled":

    $sudo lshw -C network    
  *-network DISABLED
       description: Wireless interface
       product: PRO/Wireless 5100 AGN [Shiloh] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlagn driverversion=2.6.35-28-generic firmware= latency=0 link=no multicast=yes wireless=IEEE 802.11abg
       resources: irq:48 memory:f4200000-f4201fff

In such case, the link asks me to "Check that the device is on” next:

Many wireless network devices can be turned on or off. Check to see if there is a hardware switch, some devices can be switched off from Windows and may need to be turned back on from Windows.

As I did not switch from Windows, I was wondering how to check if there is a hardware switch? How can I turn my wireless network device on? Thanks!

  • Does my network question not belong here?
    – Tim
    Apr 8, 2011 at 0:08
  • @Tim - there are sites that are more tailored to your situation, but given your answer I don't think there's any point in migrating it any more. Apr 8, 2011 at 1:26
  • @Mark: Thanks! For example, what sites?
    – Tim
    Apr 8, 2011 at 1:45
  • @Tim - for Ubuntu, there's askubuntu.com or for general "laptopish" questions, there's superuser.com - we can migrate questions to either of those sites (or for a full list, see stackexchange.com/sites) but it's generally better if you ask on the most appropriate site :) Apr 8, 2011 at 1:55
  • @Mark: Thanks! I am confused when reading this site's faq. It says that questions belonging to this site are about: Servers, Networks, or Desktop PCs that you maintain in the workplace. So is my question not about Networks?
    – Tim
    Apr 8, 2011 at 1:59

2 Answers 2


I just found the solution. There is a hardware wireless switch in front of my laptop, which was switched off accidentally.

enter image description here

I hope this will be useful for others with similar problem. Thanks for all the helping!


A couple of possibilities.

  1. A fault with the wireless network card
  2. A fault with the driver

I'd be more inclined to believe it's a driver problem.

Searching around on the net and it seems you're not alone. One forum post reads:

it seems that when you flick the switch to off it shuts the wifi down on 2 levels. turning the switch back to on fails to wake the wifi because it turns on one of these levels. it seems that the only thing that can enable the second level is lenovo's own power management program, which is windows only. so until someone comes up with a linux utility which can duplicate this behavior, you have to switch to windows and turn on the wifi everytime you change the switch to on.

The switch being talked about is the one that turns it on and off. But notice the mention of power management. Could it be related to that? Try disabling all the power management and see if it's better. If it is, then it must be related.

  • Thanks! (1) Ubuntu has its own power management and does not use Lenovo's which like you said is for Windows. Since I haven't used Windows on my laptop for a long time and during which I have booted my Ubuntu many times, I doubt if Lenovo's power management can be the culprit of my problem. (2) Anyway, how to "Try disabling all the power management"?
    – Tim
    Apr 8, 2011 at 0:06
  • I'm not really sure, I'd start looking in the BIOS.
    – hookenz
    May 1, 2011 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.