I thought that VMs exported as OVF were supposed to be completely portable, but now I see there are difference disk formats

I used the VMware ovf tool to export a VMX to OVF. The disk file created with the OVF is a VMDK.

I want to import the VM into RHEV, but the Red Hat documentation says that the accepted disk formats are RAW and COW. In contrast the VMware OVF tool says it can export to: monolithicSparse, monolithicFlat, twoGbMaxExtentSparse, twoGbMaxExtentFlat, streamOptimized, thin (vSphere target), thick (vSphere target).

How can I convert my VMDK OVF to a RAW OVF and then import it to RHEV? The documented virt-v2v tool seems to only work with VMware ESX, not vmx/vmdk/ovf images on disk.

2 Answers 2


Try qemu-img, it supports various formats for input and input.

In a last try, you can finally mount the disk on a VM and tar or dd it to another place, more friendly to other tools.

  • Good idea, tried it, but it keeps generating an error: 'qemu-img: error while reading'. Have tried various vmware ovftool export options for the disk format, but no change. (would vote up but I have insufficient reputation)
    – user62545
    Apr 8, 2011 at 15:30
  • @user updated the answer with another suggestion.
    – coredump
    Apr 8, 2011 at 15:32

OVF is basically an XML file that describes a VM, it doesn't contain it. There is a supported solution for moving VMs from VMWare, called virt-v2v.

The raw and cow formats are open formats supported by qemu, while all the vmware options are based on vmware's vmdk format.

This guide has a good description of the way virt-v2v should be used: http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Virtualization_for_Servers/2.2/html/Administration_Guide/virt-v2v-scripts.html

  • The VMDK format is mostly "open" as well - the specification is available without a license to implementors. You do have to "request" access though. vmware.com/technical-resources/interfaces/vmdk.html. I beleive the same is true of the Microsoft/Xen .VHD format.
    – rmalayter
    Jun 5, 2011 at 0:39
  • qemu supports vmdk, however it's quite common for it not to be able to recognise a vmdk that originates from a vmware setup. I guess the format specifications are not strictly adhered to
    – dyasny
    Jan 23, 2012 at 20:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .