I'm trying to install a fully virtualized guest (Fedora 14 x86_64) on KVM (RHEL 6), using command-line only (both hypervisor and guest). It goes without errors, and without a tangible result . I'd like to know how to do a text-only installation.

So, here's what I've done:

# virt-install \
--name=FE --ram=756 --vcpus=1 \
--file=/var/lib/libvirt/images/FE.img  --network bridge:br0 \
--nographics --os-type=linux  \
--extra-args='console=tty0' -v \

Starting install...
Creating domain...                                                                                                                                                        |    0 B     00:00     
Connected to domain FE
Escape character is ^]

Now what? As I understand after googling for a couple of days, I should see the guest's output from the text installation, but nothing happens. virt-viewer cannot connect to it, kindly suggesting that I explore all the options by adding --help (which I did). If I reconnect with virsh, I see this:

Domain installation still in progress. You can reconnect to 
the console to complete the installation process.
[root@v ~]
# virsh console FEConnected to domain FE
Escape character is ^]

This shows that VM is running

# virsh list
 Id Name                 State
  8 FE                   running

Qemu log:

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin /usr/libexec/qemu-kvm -S -M rhel6.0.0 -enable-kvm -m 756 -smp 1,sockets=1,cores=1,threads=1 -name FE -uuid 6989d008-7c89-424c-d2d3-f41235c57a18 -nographic -nodefconfig -nodefaults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/FE.monitor,server,nowait -mon chardev=monitor,mode=control -rtc base=utc -no-reboot -boot d -drive file=/var/lib/libvirt/images/FE.img,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=/media/usb/Fedora-14-x86_64-Live-Desktop.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=20,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:0a:65:8d,bus=pci.0,addr=0x2 -chardev pty,id=serial0 -device isa-serial,chardev=serial0 -usb -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3 
char device redirected to /dev/pts/1

Output of /etc/libvirt/qemu/FE.xml

# cat /etc/libvirt/qemu/FE.xml 
<domain type='kvm'>
    <type arch='x86_64' machine='rhel6.0.0'>hvm</type>
    <boot dev='hd'/>
  <clock offset='utc'/>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw' cache='none'/>
      <source file='/var/lib/libvirt/images/FE.img'/>
      <target dev='hda' bus='ide'/>
      <address type='drive' controller='0' bus='0' unit='0'/>
    <disk type='block' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <target dev='hdc' bus='ide'/>
      <address type='drive' controller='0' bus='1' unit='0'/>
    <controller type='ide' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
    <interface type='bridge'>
      <mac address='52:54:00:0a:65:8d'/>
      <source bridge='br0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    <serial type='pty'>
      <target port='0'/>
    <console type='pty'>
      <target port='0'/>
    <memballoon model='virtio'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>

I'm obviously missing something that many others don't, but what is it? Thanx in advance!

  • 3
    How were you able to get the --extra-args switch to work with --cdrom? According to the virt-install man page --extra-args only works with --location?
    – slm
    Commented Jun 18, 2011 at 2:27
  • 4
    I removed --network bridge:br0, changed cdromto location, and extra-args to --extra-args='console=tty0 console=ttyS0,115200n8 serial' and it worked!
    – some
    Commented Mar 16, 2013 at 4:42
  • 2
    I only changed cdrom to location and added "extra-args". No need to remove the --network options.
    – twan163
    Commented Dec 6, 2014 at 12:08
  • 1
    For whatever reason --cdrom doesn't work with extra-args but --location (or -l) does. Same path and everything. Commented Sep 30, 2015 at 23:14

6 Answers 6


I copied --extra-args='console=ttyS0' somewhere from Internet last time, it works!

  • No need for two "console" commands, that just opens two consoles instead of one
  • No need to manually specify the baud rate.
  • "--serial" option has been deprecated
  • The RedHat console device is "/dev/ttyS0", not "/dev/tty0"

See: http://anaconda-installer.readthedocs.io/en/latest/boot-options.html

  • When I used extra-args I got a warning I needed to use location. Changing cdrom=my.iso to location=my.iso solved the issue.
    – MikeKulls
    Commented May 4, 2023 at 2:24

I had a similar problem when trying to perform a text-only installation of CentOS. It all boils down to adding kernel arguments for specifying serial output console console=ttyS0 so that you can then connect to it when --graphics none or --nographics is used. From virt-install's manual:

--graphics none

No graphical console will be allocated for the guest. Fully virtualized guests (Xen FV or QEmu/KVM) will need to have a text console configured on the first serial port in the guest (this can be done via the --extra-args option). Xen PV will set this up automatically. The command 'virsh console NAME' can be used to connect to the serial device.

I've managed to solve it in two ways:

  1. by modifying the iso image and using the --cdrom option
  2. by exposing the iso image as NFS share and using the --location option with --extra-args

1. Modifying the image

In order to modify the kernel parameters on the iso installation disk:

  1. Get a program that allows manipulating images, for example, isomaster.
  2. Go to to the isolinux/isolinux.cfg file on the image, open it, find the first line with initrd= on it and append console=ttyS0 to it and all other lines that have the mentioned parameter.
  3. Save the file and the image.
  4. Use the modified image with virt-install as usual, e.g.:

    $ sudo virt-install --name centos-vm --ram 1024 --disk path=/home/user/domains/centos-vm --cdrom /home/user/images/centos-modified.iso --os-type linux --nographics --accelerate


2. Using a NFS share

  1. Mount the image:

    $ sudo mount -o loop,unhide -t iso9660 -r /home/user/images/CentOS.iso /home/user/mnt/cdrom
  2. Start the NFS service if not running: service nfs start

  3. Add the following line in /etc/exports to make it available to the clients:

    /home/user/mnt/cdrom    *(ro,insecure,all_squash)
  4. Refresh the system's export table with:

    $ exportfs -r
  5. Use the share with virt-install making sure to inculde the --extra-args, e.g.:

    $ sudo virt-install --name centos-vm --ram 1024 --disk path=/home/user/domains/centos-vm --location /home/user/mnt/cdrom --os-type linux --nographics --accelerate --extra-args="console=ttyS0"
  6. During the installation of CentOS you get a prompt asking about the location of the installation files. You have to type the address of your machine and the full path to the share.


  • i have tried your second method to mount iso file but i got this error Starting install... Retrieving file .treeinfo... | 552 B 00:00:00 ERROR No option 'kernel' in section: 'images-x86_64' i mount iso file to /mnt and use --location /mnt in virt-install Commented Jan 4, 2015 at 13:04
  • @public_name Try not mounting the iso but just specifying the path to the iso after --location like --location /tmp/centos6.iso. Commented Sep 30, 2015 at 23:18
  • Worked on Ubuntu 16, editing isolinux/txt.cfg instead of isolinux/isolinux.cfg. Commented Aug 16, 2018 at 1:55

--nographics is used, and you have no console set up in the guest, besides the tty0 console. If you want a graphical console, especially available remotely you'd need to enable vga and vnc, or qxl and spice. this is an example: http://www.linux-kvm.com/content/tip-how-run-headless-guest-machine-using-vnc-kvm

http://www.linux-kvm.com/content/running-kvm-nographics-no-console-output or http://ubuntuforums.org/showpost.php?p=9610421&postcount=7 is also a solution.

  • Thanks for answering, dyasny. Picking your points: 1. No, I do NOT want a graphical console (see my post) 2. Yes, I have been trying this and similar solutions. It didn't work for me.
    – badbishop
    Commented Apr 10, 2011 at 15:54
  • I'd try to ask on linux-kvm.org or on the libvirt mailing list
    – dyasny
    Commented Apr 12, 2011 at 17:11

You need to run the Fedora installer in text mode. Try adding 'text' to the extra args. Alternatively, you could try adding "vnc" which will allow you to connect to the installer over VNC once it is started

  • 1
    Checked it out, for a newer libvirt, you can't use -x and --cdrom. Try mounting the cdrom somewhere on the network and using --location somewhere.com/mounted-iso --graphics none --extra-args "console=ttyS0,115200 text headless"
    – katriel
    Commented Aug 7, 2011 at 21:08

I've been doing my installations for a while now using cobbler and koan. Within cobbler I set my kernel options like so under my Centos60-x86_64 profile:

Kernel Options: serial console=ttyS0,115200
Kernel Options (Post Install): console=ttyS0,115200

After boot you can use console=tty0 console=ttS0,115200 to get console to show on two devices; this doesn't work for installation. If you edit the grub options under /etc/grub and regenerate grub.conf the serial console settings will survive a kernel upgrade. Add "text" to the kernel command line to prevent installer from starting a GUI.

When my KVM guest instances start I then connect to them while logged into the KVM host and connect to a guest's console like this:

[root@vmhost ~]# virsh console guestvm

I then see this in my shell:

Connected to domain guestvm
Escape character is ^]

CentOS Linux release 6.0 (Final)
Kernel 2.6.32-71.el6.x86_64 on an x86_64

guestvm login: 

One final note, when I tell koan to start building one of my KVM guests, I call it with the --nogfx switch like so:

koan --server --virt --nogfx --system=guestvm

I'd guess you are seeing a misconfigured console.

Maybe try this or similar:

First I add console line to my grub config, e.g. for an Arch guest: kernel /vmlinuz26 root=/dev/vda2 ro console=ttyS0,115200 Then I edit /etc/inittab to enable ttyS0 (same Arch guest): co:23:respawn:/sbin/agetty -8 115200 ttyS0 linux. And make sure you have ttyS0 in your /etc/securetty.

More info here: `http://www.linux-kvm.com/content/running-kvm-nographics-no-console-output


You could try console=ttyS0,115200and check other possible console parameters maybe.

  • BTW --extra-args=takes other console settings directly too. Commented Apr 10, 2011 at 16:21
  • According to the text you've quoted, I need to modify /etc/inittab on guest. The whole problem is: how do I interact with guest? Sorry, I'm not getting it.
    – badbishop
    Commented Apr 10, 2011 at 18:27
  • Sorry see edit, I wasn't very clear. Commented Apr 10, 2011 at 18:34
  • Yes, I've tried --extra-args='console=ttyS0' as well before posting the question.
    – badbishop
    Commented Apr 11, 2011 at 6:05
  • Sorry I meant console=ttyS0,115200 and presumably there are other parameters for this that you can try. I'd still guess you have a misconfigured console of some description. Commented Apr 11, 2011 at 7:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .