This is a follow up to a pervious question. I have a Ubuntu host with a Win 2008 KVM. To improve performance the network and IO - @dyasny and the documentation recommends installing virtIO drivers. I did follow this :

Downloaded the ISO from:

Now I am not sure how to proceed. I have the Win 2008 VM already installed with the virtual disk in RAW format with an IDE bus.

I opened the iso and have several folders. Like E:\Balloon E:\NetKVM E:\vioserial E:\viostor

I am assuming NetKVM is for the network drivers and viostor is for the disk drivers. For the NetKVM, there is only Vista and XP sub-folders.

Similarly for the viostor: there is a folder structure like below. E:\viostor\Win7 E:\viostor\Wlh E:\viostor\Wnet E:\viostor\WXp

So in summary, my questions:

  1. Which folders should we use for Win 2008 64 bit?
  2. How do I install the NetKVM for an existing VM?
  3. How do I ins tall the viostor for an existing VM?
  4. Finally, just out of curiosity, what is Ballon and vioserial drivers for?

Thanks a ton for your help!

2 Answers 2


so, as I already mentioned - you have 3 options:

  1. hack windows to accept virtio drivers for the boot device (highly unrecommended) and then switch the disk interface to virtio
  2. reinstall with virtio, using the drivers you mention this time on a floppy image or ISO attached to the VM
  3. slipstream the virtio drivers into your windows ISO and reinstall
  • Hi Dyasny, I decided to just reinstall this from the get go. So I used virt-manager to create a new VM and then adjusted the storage to remove the IDE and added a virtIO drive. I use the floppy (vfd) based drivers, which help recognize the unallocated drive. However, after the drive shows up as allocated - Windows installation is unable to proceed. It says "Windows is unable to find a system volume that meets its criteria for installation.". I tried partitioning nothing worked. Any ideas. It is 64 bit btw?
    – taazaa
    Apr 17, 2011 at 22:58
  • Looks like this is a known bug: reported here https://bugzilla.redhat.com/show_bug.cgi?id=568294. Basically we need to make sure the hd is set to be bootable. Either we need to say boot=on at the command line or in my case I just changed the xml using virsh to include <boot dev='hd'/> after the cdrom boot. Thanks for your help again.
    – taazaa
    Apr 18, 2011 at 3:55
  • glad you figured it out. Yes, qemu requires the disk is set to bootable, and the management should do that automatically for a new guest. It actually works for me on my F14 laptop
    – dyasny
    Apr 18, 2011 at 6:35
  • I am using F14, I think (the latest vfd is F14?) and virt-manager to setup the VM. Subjectively speaking, the IO performance with virtIO drivers is much better based on the responsiveness of the application (asp.net app). Now just have to test it for sustained periods of time to make sure everything is working as expect. So far so good.
    – taazaa
    Apr 19, 2011 at 16:20
  1. I would hazard a guess at the latest versions (Vista / Win7), windows won't happily install drivers that it can't support.
  2. Add a virtio nic, start the VM, install drivers when Windows looks for them, remove non-virtio nic.
  3. Add a temporary virtio disk, install drivers, remove temp disk and change your boot disk to virtio.
  4. The Balloon driver is for Memory Ballooning, but I have never managed to install it on any of my VM's, vioserial is apparently so you can have more than one serial port.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .