3

Ok, we have a web server that we remote desktop into from a Windows XP Pro box. The server is Windows Server 2003 R2 Standard Edition, Service Pack 2.

When we log into the server after a windows update it notifies us that it would like to restart the server and gives us two options: 1) Restart Now 2) Restart Later.

In this situation I always click 'Restart Later' and then finish what I need to do on the server. If I log off my remote desktop it then restarts the server. This is not what we want, is there some way to make it not restart?

It seems like my only option is to close the remote desktop connection(by clicking the X button on top right), but when I do that we need to request a trouble ticket to disconnect my RDP connection.

So it seems like I have two options in the above situation:

  1. Log off server and have our server which provides several services be out of commission for 5-10 minutes while it is restarting
  2. Close my RDP connection and have no way to get into the server until tech support resets my RDP connection.

Is there another option?

EDIT:

After more searching on this site I found this question/answer and it seems like the first answer will take care of my situation, does anybody agree?

2

Your server is almost certainly set to automatically download and install updates, but to not force a restart while someone is logged in. There are local or group policy settings that handle this. When you log off, there's no user logged in to prevent the restart anymore. It's that simple.

0

My suggestion, turn off your automatic updates. I live by the policy that updates on a server should never happen automatically. Its all too often that an update will get installed that causes some kind of undesired issues. I prefer to monitor when updates get loaded.

0

I ran into same problem and i tried following ..

Have you checked the always informative event logs? Start >> run >> eventvwr

Also, is "Automatically Restart" selected in the startup and recovery options? Right click my computer >> properties >> advanced tab >> startup and recovery >> uncheck "Automatically restart".

Make sure to peruse the log files to see what's going on!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.