I'm getting the following error when I try to go into the "Content Sources" section of the Search Administrator in the SSP.

The search service is currently offline. Visit the Services on Server page in SharePoint Central Administration to verify whether the service is enabled. This might also be because an indexer move is in progress.

I know that the service is started, and that the index is not being moved.

The Crawl Status is Error.

I have reconfigured the Search, and still I get the same error. The account running the service has the correct security settings on the SQL Server.

  • Definitley need more details on this, please check the event logs and SharePoint logs and post any relevant information. – MattB Jun 15 '09 at 19:10
  • Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (88ef2e63-8897-4bff-8473-f1a19b5ad59b). Reason: Object b2fb0953-2f86-4187-a9ae-602f9d65cb31 not found. – maxtopus Jun 15 '09 at 19:17

The event log should have more and better information. What does it say?

| improve this answer | |

It looks like the search or indexing service (or both) has entered into an inconsistent state. Stop both the search and indexing service which should remove their files, then start them again. Your configuration should be kept, although you may wish to make a note of it just in case.

If you can provide any more details about the configuration of your farm, particularly which servers run each service, that would help. Also the service pack and/or cumulative update level you are patched to.

| improve this answer | |
  • The server runs all roles WFE/Indexing/Query and the other is just a SQL 2005 DB. The Version currently running is I stopped and started the services as you suggested. However, it remains saying "Error" on the Crawl Status. What I did notice is that when I click on "Content Sources" it gives me a HTTP 403 Forbidden. – maxtopus Jun 15 '09 at 20:04
  • Now I'm getting "Exception from HRESULT: 0x80040D1B" when I go to "Content Sources" – maxtopus Jun 15 '09 at 20:14
  • 1
    OK, I can help you with the 403. Have a look at support.microsoft.com/kb/926959 – Alex Angas Jun 15 '09 at 20:18
  • I tried this, however I got the same error back. – maxtopus Jun 16 '09 at 21:00

In order to solve this I had to create a new SSP. Reconfigure it to match my all settings and place all my web applications on the new SSP. In addition, when creating the Crawl Schedule, I got the Access Denied issue and solved as suggested by Alex.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.