5

I am writing a script that emails the output to me, and I read it in Outlook. For some reason Outlook removes all the line breaks in the message, and gives me a little notice that it has removed the extra line breaks from the message

How can I fix my message so that Outlook doesn't remove the line breaks?

  • Outlook displays other messages fine (with correct line breaks)
  • I have tried all these things with sed - s/$/\r/ s/$/\n/ s/\r\n/\n/ s/\n\r/\n/ s/$/^M/ - with no luck

What does Outlook expect at the end of a line?

2
  • I'm thinking.. shouldn't programming questions be posted in stackoverflow instead?
    – Wadih M.
    Jun 15 '09 at 18:58
  • I put it here because I thought it would be more applicable to sysadmins than programmers.
    – Brent
    Jun 15 '09 at 19:24
6

Not sure about what it's looking for, but how about configuring Outlook to not remove them?

Tools -> Options -> Preferences Tab -> click E-mail Options button -> uncheck the box

Another option (albeit not ideal and maybe not even the case for your msgs):

  1. Open Outlook.
  2. Open the item.
  3. Click Format.
  4. Click to clear the Unwrap Text check mark.

And here's a post that says that a hack you can use would be to add 2 empty characters to the beginning of each line of text in order to make Outlook not remove the breaks.

Additionally see here for a better layout, add at least 3 spaces at the end of every line (incl. empty lines).

9
  • 2
    He's asking how Outlook parses the mails, not how he can shut off the behaviour in Outlook.
    – pauska
    Jun 15 '09 at 18:03
  • Yeah, I know. But frequently other suggestions end up working better than the requested functionality. I also posted a hack more toward what he was asking.
    – squillman
    Jun 15 '09 at 18:08
  • Dude. The problem is "Outlook is misbehaving", not "the message is broken". Fix the Outlook problem. Jun 15 '09 at 18:15
  • See also serverfault.com/questions/26004/… Jun 15 '09 at 18:18
  • Ok - you edited and it looks a bit more helpful now, I'm taking my -1 back
    – pauska
    Jun 15 '09 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.