I have created a very simple ASP.NET MVC3 application that runs just fine in the Visual Studio debugger.

However, I have tried to add this application to my local IIS installation. I added the project by right-clicking Sites and clicking "Add Web Site" (specifying the project's folder and setting port to 9000).

However, firing up Chrome and going to http://localhost:9000 yields the following error:

enter image description here

It looks like some sort of permissions problem, but I have no idea what I would do to fix this.

More details:

  • OS: Windows Vista Home Premium 32-bit
  • IIS: 7.0.6000.16386
  • Visual Studio 2010 Express with SP1

You can this out:


It looks like something is wrong with your Temp folder permissions.

  • Yup - that was the problem. I gave IIS_IUSRS full access to the temp folder and it works now. Apr 18 '11 at 1:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.