I have VMware Server working on a server running Ubuntu Server 10.04. After many troubles getting it going, I have one virtual machine running and I'm now stuck with a browser issue.

Firefox won't load VMware Infrastructure Web Access. When going to https://<ip-of-server>:8333 it shows a blank page, the title of which says "Loading..." while it is quite apparent (as with the status bar) that it has finished loading. I have tried this on both Firefox 3.6 and Firefox 4.

Chrome doesn't have the VMware Remote Console Plug-in available, so it isn't even an option. However the VMware Infrastructure Web Access does load on chrome at https://<ip-of-server>:8333.

I was able to install Internet Explorer 7 through PlayOnLinux and I did get IE7 running. When I go to https://<ip-of-server>:8333 it gives me the same certificate error that chrome gives but when I click on "Continue to this website (not recommended)" it just seems to refresh the page... doesn't actually take me past this error to the console.

Right now I'm stuck for browsers to be able to get the VMware Remote Console Plug-in. Firefox would be the best option as I'm not much of a fan of IE7 and Chrome doesn't seem like an option unless VMware does something about it.

If anyone has any ideas please let me know. Any help is appreciated!

EDIT: If you require more information please ask. I'm not sure what else to include.


The solution is to use Firefox 3.5 or below (link to old Firefox downloads), since Firefox 3.6 or higher doesn't work with the VMware remote console plugin - since this is already not getting security updates, it's best to install it separately to the main Firefox, and use a new profile. To avoid messing up any Ubuntu version of firefox, just untar the Firefox 3.5 tar.gz under something like /opt/firefox-3.5

Here's a shell script that invokes this Firefox with the right profile, even if you have a more recent Firefox running (via the -no-remote):

# Run Firefox 3.5, for VMware 2.0 only
exec $prog -no-remote -P vmware-FF3.5

After you are done with the console, it's best to close the Firefox 3.5 instance, otherwise links clicked in other applications may open in the 3.5 instance.

A different partial solution is to use VNC to login to the VM once it's started some other way - this doesn't give you all the remote console features so you'd need to use the VMware shell commands on the host to manage the VM. See this HOWTO - however, this doesn't support VNC over SSL so SSH tunnels are recommended.

VMware Server 2.0 is reaching end of support in June 2011, and there haven't been updates for a long time to work with newer Firefox versions, so it is probably time to look for alternatives.

| improve this answer | |
  • Thanks for the excellent answer! Switched to VMware ESXi, I had no clue they were dropping support. Sorry I didn't catch it in time to award full bounty... Thanks again! – user29600 Apr 28 '11 at 19:51

I've encountered this problem many times when working with VMware Server, and it is one of the reasons that I try to avoid Server these days and use ESXi as much as possible. But if you really need server, here are some of the things that I've found help (and I realize that some of them probably won't work for you, or don't apply, because you've already tried them).

  1. Make sure that the correct hostname is in /etc/hosts in Ubuntu for at least the localhost ( entry.

  2. Try a version of Firefox that was around when Server was last released/updated.

  3. Make sure you installed following the instructions here: https://help.ubuntu.com/community/VMware/Server, including the patches that are listed as one of the steps. Note that the instructions for 10.04 are the same as the 9.10 instructions, and the link to the patches may be out of date (but this one still works for me: http://radu.cotescu.com/how-to-install-vmware-server-ubuntu-fedora-opensuse/).

| improve this answer | |

Not sure what IE7 for Linux actually is built around, but I know I've experienced issues after upgrading Firefox on some of my Linux machines. The plugin used for both Server and ESXi is incompatible with newer versions of Firefox (NPAPI change?). Read http://communities.vmware.com/message/1462526 for similar issues described.

How I got around it was just installing a second version of Firefox (3.5) on my machine and using that for accessing the server where ESXi was installed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.