I have a lot of trouble trying to host xen 4 on my dedicated server. I first tried centos, it had only xen 3, but everything went amazingly smooth - I had win xp up & running in few minutes. However, I want to host windows server 2k8 r2 and it needs xen in a version at least 4.0.

I've tried debian and opensuse, both has xen 4 as packages, but both seems to be unstable. I don't know what exactly happens, but the server became unreachable during guest boot and every single dom0 reboot. The problem is, the panel my hoster (hetzner.de) has the option to do hw reset, but... it seems to stop working when it freezes. Each time that happens, I have to order a manual hw reset, and have to wait about half an hour for staff to react. It makes it completely impossible to find the issue :( the staff usually responds with something like 'it was a black screen' or 'it was frozen'. Do you guys have any ideas how I could try to "debug" it? Or maybe any good xen replacement...?

KVM is above my budget (it's more expensive than a server itself...), and dc is way too far and probably I couldn't get there anyway...

I have completely no idea what else I could try or where to look for help. I feel so useless right now...

  • Contact Hetzner support? Dec 20 '11 at 13:39

Quick question: what's your cpu? I just had a similar issue it was with xcp where it would hang and require a manual power off. Check in your bios in the processor section and see if c-state is enabled. If so, disable it and see if it fixes your issue.

  • It's intel i7 920. I'm not sure whether I am able to change something in the bios, I will have to call support I guess.
    – trakos
    Apr 19 '11 at 0:20
  • I would def look into this as it is on the list of processors with issues.
    – gdurham
    Apr 19 '11 at 0:27
  • I realized that for hosting a windows server 2k8 r2 xen 3.4 is sufficient, so I went for centOS and added unofficial gitco repositories, installed xen 3.4 and the crashes are gone, while I can boot windows server 2k8 r2 - I'm fully happy with that setup for now.
    – trakos
    Apr 20 '11 at 18:15
  • The proppable reason why you don`t see the blackouts any more is that xen 3.4 does not support the power-saving-functions. 4.x does - and then you will run into the C-state issue mentioned by gdurham.
    – Nils
    May 18 '11 at 19:38

Stay with xen3 unless you know exactly what xen4 gives you. You may have issues running HVM guests with Hetzner routed network setup though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.