I rebooted our 2k3 server box, and it looks like its hanging for some reason and I can't connect via terminal services to investigate. Any suggestions to resolve this issue?


  • Working on vpn - server is a stand alone sql server - no domain - development environment
  • Can ping
  • SQL Service, everything else is running fine, just cant connect via RD, trying console doesn't work either.

Update 5:41 PM EST

  • tried using psShutdown -r -f, and shutdown /r/f with no luck. I think I did manage to take out the RPC service though as it is no longer responding.
  • It's still responding to pings though. Also, just for kicks I tried to telnet to the remote port, something seems to be listening on 3389.

  • When trying to use mstsc in any mode i get the Remote Desktop Disconnected Message.

6:04 PM EST - Going to need a manual reboot I think. Thanks everyone for the advice, I learned some good tips.

  • You've got a huge can of worms there. There are so many things that can be at play. You should qualify if you're able to reach the server via other protocols and describe the network topology a bit (both client and server on same LAN, server behind firewall, client behind NAT, etc). Jun 15, 2009 at 20:24
  • 2
    It doesn't help you right now, but I'd advise you use the shutdown command for rebooting remote servers in future. I've had this happen enough that it's become a habit already. Instead of a regular GUI shutdown, just run this from command prompt or Run box: shutdown -r -t 0 -f. -r for reboot, -t 0 for immediate reboot (0 sec countdown) and most importantly, -f to force the reboot. Jun 15, 2009 at 21:05
  • 1
    Yeah, but if his RPC services are being wacky, he won't be able to run a remote `shutdown'.. Jun 15, 2009 at 21:13
  • Yeah, unfortunately manual reboots sometimes are required. I've seen the login services fail to come up after apply updates over the years, especially on servers that have been in service for a while.
    – Tatas
    Jul 20, 2009 at 23:35

7 Answers 7


Does your server have multiple NIC's installed? We ran into a behavior that occurs on some servers where the server gets rebooted but you cannot connect via RDP, but it doesn't happen every time.

We finally tracked it down to an obscure bug (IMHO) where having the RDP bound to all interfaces (which is the default) can cause the behavior. Fortunately, the first server we had that happen on had a DRAC which allowed us to correct the problem remotely. The second one did not.

The solution was to explicity bind RDP to the interface it was suppose to be using. Since then we haven't had a problem. In the case of our second server we were able to issue a reboot command from another machine on the network and when it came back up we were able to connect and fix the issue. The command was:

shutdown /r /f /t 000 /m \\<servername>

or you can use this command to show the GUI for it

shutdown /i
  • I don't believe it has multiple NICs.
    – mrjoshua
    Jun 15, 2009 at 21:41
  • Ok, this doesn't apply then. You may want to verify that, I know a lot of boxes these days come with two by default, and it's a good one to keep in mind for new purchases.
    – palehorse
    Jun 16, 2009 at 18:35
  • @palehorse The shutdown command saved my life, thank you so much. :) I actually ran it from the same PC I RDP'd from and it still worked. Although what do you mean "explicitly bind RDP?"
    – Chiramisu
    Sep 7, 2012 at 2:24

After reading all the descriptions of what's going on, (greyed out controls, unable to RDP, etc.) I'd bet a soda pop that your RPC service is having great difficulty, (and/or is possibly affecting your server service.)

If this is the case, none of the pstools will work, (psexec, pslist, etc.)

And if time is of the essence, suggest wrangling a user on-site to perform a hard power down/up. I'd probably also have the user watch for RAID errors, during boot process.

Good luck, mate.. I've been where you are, before :)


I'm assuming that you can ping the server. Try accessing the server's services via Computer Management on your desktop and make sure that Terminal Services is up and Running.

  • The service says started, controls appears to be grayed out though.
    – mrjoshua
    Jun 15, 2009 at 20:30
  • 2
    If you are not able to stop/re-start the service because it is grayed out, it could be hung. I would recommend downloading PSKILL from Microsoft's Sysinternals @ technet.microsoft.com/en-us/sysinternals/bb896683.aspx - this will allow to stop the process. Then try starting it again from the Services. If that doesn't work, you need to restart.
    – ichiban
    Jun 15, 2009 at 20:39
  • 1
    Perhaps try switching the service to manual, reboot, let the server come up nicely then start it up and see if you get any further?
    – Mitch
    Jun 15, 2009 at 20:40
  • I wasn't aware of those tools. Thanks for the great link. I think if I can reboot it will solve the issue. Unfortunately, psShutdown isn't working either.
    – mrjoshua
    Jun 15, 2009 at 21:23

Have you tried accessing the terminal server though a MSTS console switch?

mstsc -v:servername /F -console

You should try this if regular TS connection fails

  • console mode doesn't work either
    – mrjoshua
    Jun 15, 2009 at 21:21

I have had this problem with remote servers (in a colo) and had to use a DRAC to reboot it. If someone has physical access to the box your best bet is to have them reboot it.

I am curious to try the approach from palehorse next time I hit this problem, though.


What error are you getting when you try to connect? If it is that the server has exceeded the number of connections, then the /console suggested by an earlier poster will do the trick.

If you have console access, or can gain some sort of Remote Control, Try disabling the RDP Service, rebooting, then enabling the Service. We recently had a Server where RDP would not connect (Timeout Error), and this solved the issue, although we have not determined the root cause.

In a pinch, we've used DameWare to get to servers that where not responding to RDP. The link to their website is DameWare

The Shutdown recommendations are good advice.


Don't forgot to turn in on in the Properties tab of the system app.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .