Working off of my last question, I can access my server's FTP over the LAN but not over the internet. I'm using Filezilla on port 666. My router/modem configuration is as such (similar to other post):

1) Modem connects to WAN
2) WAN port on modem connects to LAN port on Router
3) Modem internal IP address is
4) Router internal IP address is
5) Modem has DHCP turned OFF
6) Router has DHCP turned ON
7) Router is running Tomato firmware and it's set as 'Router' (not 'Gateway')
8) The internet is working (just had to say that)

I've set up port forwarding both on the modem and router - both route port 666 to the IP address of (TCP); that is the IP address of the server which has FileZilla running. I don't know if that's hindering anything but I've also tried it with just the modem and just the router...same result. I've also tried setting the server to be DMZ (both on router and modem).

Neither router nor modem have anything in their logs about denying inbound traffic on port 666 so my ability to troubleshoot stops there. I've tried contacting my ISP (Telus, running on mobility plan...it's a "Smart" Hub) but they weren't much help. They said they only block port 25 and 80 and maybe a few others, but not most ports. I test whether or not the port is open by going to canyouseeme.org - I don't know whether or not that would produce a 'connection refused' result just based on the fact that the FTP requires a login...I'm not well versed on this matter.

FWIW, sometimes I get a 'connection refused' error on canyouseeme.org but mostly it's 'connection timed out'.

I don't know what else to do at this point.


From what I can see of canyouseeme.org as you are getting failed connections, one way or another, then the port forwarding cannot be working.

If you do not need to have the modem to connect to the Internet then leave that out of the link, that's one less thing to cause a problem.

Connect the router to your ADSL/cable by its WAN port (dodgy naming convention, but we can ignore that).

Link the server to the DMZ port on the router, make sure that the IP address of the router's DMZ port is in the same subnet as the host, use something like for the router and for the server.

On the router Enable forwarding of traffic for port 666 to your server.

If the router has a firewall or access control list separate from the port forwarding config make sure that port 666 is allowed.

Check if you can get to the wider world from the server.

If none of the above works, the replace the router with the modem and apply the same settings but change to DMZ port to LAN port since presumably the modem only has WAN(?) and LAN ports.


It seems Telus is blocking all incoming ports! Of course their tech support failed to mention that the first time around...I'm on their mobile internet plan (as I'm out in the county...no hard-line connections :^< )

Is there any FTP-like solution? I've read that they block TCP ports (not that they block UDP as well...but I don't know).

  • Without the ability to use TCP for inbound connections I think you are probably stuck. The only file transfer protocol I know of that uses UDP is TFTP and there is no security with that so it's a definite no-no. Anyway, I suspect that if they are blocking TCP they might well be blocking UDP as well.
    – blankabout
    Apr 22 '11 at 16:28

Telus gives your ZTE a internal WAN address Rather than a external Wan address and don't have there service provider internal router set for bridge mode so all port forwarding is blocked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.